Bug 152303 - Dependency failure on update
Dependency failure on update
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-27 18:19 EST by Sean Bruno
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 1.9.88-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-01 13:20:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sean Bruno 2005-03-27 18:19:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050325
Firefox/1.0.2 Fedora/1.0.2-2

Description of problem:
I am unable to update openoffice.org-core to latest rawhide.  I installed FC4T1
with the "Everything" install, so all language packs are installed.

Version-Release number of selected component (if applicable):
openoffice.org-core-1.9.83-1

How reproducible:
Always

Steps to Reproduce:
1.  Install FC4T1 with "Everything" for package selection
2.  After install, attempt to update via yum with "yum -y update
openoffice.org-core"
3.
    

Actual Results:  Update fails against rawhide with dependency errors

Expected Results:  openoffice should update...see additional information for
package dependencies.

Additional info:

Error: Missing Dependency: openoffice.org-core = 1:1.9.83-1 is needed by package
openoffice.org-langpack-kn-IN
Error: Missing Dependency: openoffice.org-core = 1:1.9.83-1 is needed by package
openoffice.org-langpack-eu
Error: Missing Dependency: openoffice.org-core = 1:1.9.83-1 is needed by package
openoffice.org-langpack-nb
Error: Missing Dependency: openoffice.org-core = 1:1.9.83-1 is needed by package
openoffice.org-langpack-el
Error: Missing Dependency: openoffice.org-core = 1:1.9.83-1 is needed by package
openoffice.org-langpack-hu
Error: Missing Dependency: openoffice.org-core = 1:1.9.83-1 is needed by package
openoffice.org-langpack-gl
Error: Missing Dependency: openoffice.org-core = 1:1.9.83-1 is needed by package
openoffice.org-langpack-zh-TW
Error: Missing Dependency: openoffice.org-core = 1:1.9.83-1 is needed by package
openoffice.org-langpack-da
Error: Missing Dependency: openoffice.org-core = 1:1.9.83-1 is needed by package
openoffice.org-langpack-pt-BR
Error: Missing Dependency: openoffice.org-core = 1:1.9.83-1 is needed by package
openoffice.org-langpack-hi-IN
Error: Missing Dependency: openoffice.org-core = 1:1.9.83-1 is needed by package
openoffice.org-langpack-tn
Error: Missing Dependency: openoffice.org-core = 1:1.9.83-1 is needed by package
openoffice.org-langpack-sk
Error: Missing Dependency: openoffice.org-core = 1:1.9.83-1 is needed by package
openoffice.org-langpack-eo
Error: Missing Dependency: openoffice.org-core = 1:1.9.83-1 is needed by package
openoffice.org-langpack-tr
Error: Missing Dependency: openoffice.org-core = 1:1.9.83-1 is needed by package
openoffice.org-langpack-zh-CN
Error: Missing Dependency: openoffice.org-core = 1:1.9.83-1 is needed by package
openoffice.org-langpack-he
Error: Missing Dependency: openoffice.org-core = 1:1.9.83-1 is needed by package
openoffice.org-langpack-ko
Error: Missing Dependency: openoffice.org-core = 1:1.9.83-1 is needed by package
openoffice.org-langpack-pl
Error: Missing Dependency: openoffice.org-core = 1:1.9.83-1 is needed by package
openoffice.org-langpack-pt
Error: Missing Dependency: openoffice.org-core = 1:1.9.83-1 is needed by package
openoffice.org-langpack-et
Error: Missing Dependency: openoffice.org-core = 1:1.9.83-1 is needed by package
openoffice.org-langpack-fi
Error: Missing Dependency: openoffice.org-core = 1:1.9.83-1 is needed by package
openoffice.org-langpack-ns
Error: Missing Dependency: openoffice.org-core = 1:1.9.83-1 is needed by package
openoffice.org-langpack-cs
Error: Missing Dependency: openoffice.org-core = 1:1.9.83-1 is needed by package
openoffice.org-langpack-af
Error: Missing Dependency: openoffice.org-core = 1:1.9.83-1 is needed by package
openoffice.org-langpack-lt
Error: Missing Dependency: openoffice.org-core = 1:1.9.83-1 is needed by package
openoffice.org-langpack-cy
Error: Missing Dependency: openoffice.org-core = 1:1.9.83-1 is needed by package
openoffice.org-langpack-ca
Error: Missing Dependency: openoffice.org-core = 1:1.9.83-1 is needed by package
openoffice.org-langpack-zu
Error: Missing Dependency: openoffice.org-core = 1:1.9.83-1 is needed by package
openoffice.org-langpack-ms
Error: Missing Dependency: openoffice.org-core = 1:1.9.83-1 is needed by package
openoffice.org-langpack-ja
Error: Missing Dependency: openoffice.org-core = 1:1.9.83-1 is needed by package
openoffice.org-langpack-nn
Error: Missing Dependency: openoffice.org-core = 1:1.9.83-1 is needed by package
openoffice.org-langpack-th
Error: Missing Dependency: openoffice.org-core = 1:1.9.83-1 is needed by package
openoffice.org-langpack-sl
Error: Missing Dependency: openoffice.org-core = 1:1.9.83-1 is needed by package
openoffice.org-langpack-bg
Comment 1 Sean Bruno 2005-03-31 22:22:28 EST
I am now missing only 3 language packages for OO.org.  On a yum update
openoffice.org-core, I get the following errors:

Error: Missing Dependency: openoffice.org-core = 1:1.9.83-1 is needed by package
openoffice.org-langpack-eo
Error: Missing Dependency: openoffice.org-core = 1:1.9.83-1 is needed by package
openoffice.org-langpack-tn
Error: Missing Dependency: openoffice.org-core = 1:1.9.83-1 is needed by package
openoffice.org-langpack-ns

Should these be updated or should I delete them from my installation?
Comment 2 Caolan McNamara 2005-04-01 03:07:00 EST
Yeah, I added the Obsoletes for the other packages whose name I changed, but
those three are languages which OOo claims to support, but fedora itself doesn't
so I dropped them. 
Comment 3 Sean Bruno 2005-04-01 03:08:41 EST
Cool.  Do you want me to delete these three RPM's? 
Comment 4 Caolan McNamara 2005-04-01 03:25:04 EST
Yeah, do that. I'll also Obsolete those three langpacks in the next respin
Comment 5 Sean Bruno 2005-04-01 03:47:38 EST
Done.  Close the ticket when u are done with it.  ty
Comment 6 Caolan McNamara 2005-04-01 13:20:18 EST
Will be good in 1.9.88-5

Note You need to log in before you can comment on or make changes to this bug.