Bug 152312 - DRI doesn't work on Sharp MM20 (ATI Radeon Mobility 7500)
DRI doesn't work on Sharp MM20 (ATI Radeon Mobility 7500)
Status: CLOSED DUPLICATE of bug 144867
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-28 01:20 EST by H. Peter Anvin
Modified: 2015-01-04 17:18 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-03 21:11:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description H. Peter Anvin 2005-03-28 01:20:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
With kernel-2.6.10-1.770_FC3, DRI does not work on a Sharp MM20 (ATi Radeon Mobility 7500 GPU, Transmeta Efficeon TM8600 CPU/northbridge.)  With kernel-2.6.9-1.667, it does work.

Version-Release number of selected component (if applicable):
kernel-2.6.10-1.770_FC3

How reproducible:
Always

Steps to Reproduce:
1. Make sure DRI is enabled in xorg.conf.
2. Start X.
  

Actual Results:  The cursor has the proper shape, but the screen displays whatever crap was in video memory.

(This is a common failure mode when DRI is unable to DMA.)


Expected Results:  Display login splash screen.


Additional info:
Comment 1 Warren Togami 2005-03-28 02:57:11 EST
http://people.redhat.com/davej/kernels/Fedora
Any better with the latest test kernel from here?  (Make sure you upgrade to
FC3updates udev before booting the 2.6.11 kernels.)
Comment 2 David A. Cafaro 2005-04-07 23:02:08 EDT
Sounds like you are having the same issue I'm having with my bug here:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=144867

The 2.6.9 kernels seem to work fine with DRI enabled, but any kernel after that,
including the 2.6.11 one in FC3 testing locks good and hard.  

Please ignore any earlier posts on that bug report about 2.6.9 kernels also
causing lockups, I have not been able to repeat that and the 2.6.9 kernels have
run fine.
Comment 3 David A. Cafaro 2005-04-12 09:56:31 EDT
Still locking in kernel-2.6.11-1.14_FC3
Comment 4 David A. Cafaro 2005-04-18 13:23:50 EDT
Ok, I tried something new, and narrowed the issue down to something with the AGP
driver used.  By using Option "BusType" "PCI" and forcing the xorg to use the
AGP card as a PCI card, everything works as expected.  The only issue being that
it is slower than Using AGP mode. 

I also filed a bug upstream with kernel.org since I found the same issue with a
2.6.11.6 kernel I compiled from them.  That bug can be found here:
http://bugzilla.kernel.org/show_bug.cgi?id=4513
Comment 5 Dave Jones 2005-07-15 15:33:03 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 6 David A. Cafaro 2005-07-20 10:06:43 EDT
Unfortunately, the problem persists with the latest kernel.  Currently running
kernel-2.6.12-1.1372_FC3 with xorg-x11-6.8.2-1.FC3.13 on Fedora Core 3.  Same
issue as before, still get the moving mouse on a black screen with screwed up
images at the very top.  No keyboard response, but the system isn't locked, can
ssh in and cleanly shutdown the system.  With Option "BusType" "PCI" set the
system will boot into xwindows with DRI enabled.  With out setting it to "PCI"
then the screen locks as described above.  

I have not tried FC4 on this system yet.
Comment 7 Dave Jones 2005-08-03 21:11:55 EDT

*** This bug has been marked as a duplicate of 144867 ***

Note You need to log in before you can comment on or make changes to this bug.