Bug 152314 - Pango errors
Pango errors
Status: CLOSED DUPLICATE of bug 155853
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: eclipse-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-28 10:00 EST by Billy Biggs
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-28 17:10:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Billy Biggs 2005-03-28 10:00:49 EST
I see these warnings from pango when running a gcj-compiled eclipse.  I do not
see them when running under the Sun JRE.  They occur when flipping through pages
in the Find dialog, and also in the Run dialog.

** (<unknown>:18022): WARNING **: Invalid UTF8 string passed to
pango_layout_set_text()

** (<unknown>:18022): WARNING **: Invalid UTF8 string passed to
pango_layout_set_text()

** (<unknown>:18022): CRITICAL **: file pango-layout.c: line 1773
(pango_layout_get_cursor_pos): assertion `index >= 0 && index <= layout->length'
failed

** (<unknown>:18022): CRITICAL **: file pango-layout.c: line 1773
(pango_layout_get_cursor_pos): assertion `index >= 0 && index <= layout->length'
failed
Comment 1 Ben Konrath 2005-04-26 17:06:49 EDT
I couldn't reproduce this on a rawhide system (gcc*-4.0.0-1,
eclipse*-3.1.0_fc-0.M6.11). Can you try this again with updated packages?
Comment 2 Ben Konrath 2005-04-28 17:10:07 EDT
I managed to reproduce this and we should track this through bug #155853.

*** This bug has been marked as a duplicate of 155853 ***

Note You need to log in before you can comment on or make changes to this bug.