Bug 152345 - eclipse dies at startup
eclipse dies at startup
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: eclipse-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-28 13:41 EST by John Ellson
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-19 16:45:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
stdout from eclipse command (13.40 KB, text/plain)
2005-03-28 13:41 EST, John Ellson
no flags Details
/home/ellson/workspace/.metadata/.log (12.20 KB, text/plain)
2005-03-28 13:42 EST, John Ellson
no flags Details

  None (edit)
Description John Ellson 2005-03-28 13:41:29 EST
Description of problem:
eclipse dies at startup

Version-Release number of selected component (if applicable):
eclipse-platform-3.1.0_fc-0.M5.14

How reproducible:
100%

Steps to Reproduce:
1. rm -rf .eclipse workspace
2. eclipse -consolelog -debug >eclipse.out
3.
  
Actual results:
splash screen, then popup that reads:
An error has occurred. See the log file "/home/ellson/workspace/.metadata/.log".

Expected results:
no crash

Additional info:
Comment 1 John Ellson 2005-03-28 13:41:29 EST
Created attachment 112392 [details]
stdout from eclipse command
Comment 2 John Ellson 2005-03-28 13:42:42 EST
Created attachment 112393 [details]
/home/ellson/workspace/.metadata/.log
Comment 3 John Ellson 2005-03-29 17:10:16 EST
Same problem today with: eclipse-platform-3.1.0_fc-0.M5.15
Comment 4 Ben Konrath 2005-04-04 13:18:33 EDT
Hi, Can you post the output of these two commands:

ls -l /usr/lib64/eclipse/plugins/org.eclipse.swt.gtk_3.1.0/ws/gtk
ls -l /usr/share/eclipse/plugins/org.eclipse.swt.gtk_3.1.0/ws/gtk
Comment 5 John Ellson 2005-04-04 16:21:28 EDT
ellson@ontap:~> ls -l /usr/lib64/eclipse/plugins/org.eclipse.swt.gtk_3.1.0/ws/gtk
ls: /usr/lib64/eclipse/plugins/org.eclipse.swt.gtk_3.1.0/ws/gtk: No such file or
directory
ellson@ontap:~> ls -l /usr/share/eclipse/plugins/org.eclipse.swt.gtk_3.1.0/ws/gtk
ls: /usr/share/eclipse/plugins/org.eclipse.swt.gtk_3.1.0/ws/gtk: No such file or
directory

Probably it wants the gtk64 versions instead?

ellson@ontap:~> ls -l /usr/lib64/eclipse/plugins/org.eclipse.swt.gtk64_3.1.0/ws/gtk
total 9124
-rwxr-xr-x  1 root root   88432 Apr  4 00:06 swt-cairo.jar.so
-rwxr-xr-x  1 root root  405392 Apr  4 00:06 swt-mozilla.jar.so
-rwxr-xr-x  1 root root 1378872 Apr  4 00:06 swt-pi.jar.so
-rwxr-xr-x  1 root root 7422616 Apr  4 00:06 swt.jar.so
ellson@ontap:~> ls -l /usr/share/eclipse/plugins/org.eclipse.swt.gtk64_3.1.0/ws/gtk
total 1200
-rw-r--r--  1 root root    4064 Apr  3 23:47 swt-cairo.jar
-rw-r--r--  1 root root   53865 Apr  3 23:47 swt-mozilla.jar
-rw-r--r--  1 root root  112931 Apr  3 23:47 swt-pi.jar
-rw-r--r--  1 root root 1023266 Apr  3 23:47 swt.jar
Comment 6 Ben Konrath 2005-04-04 18:18:55 EDT
Yeah, I meant the swt.gtk64 directory, thanks. As you can guess I don't actually
have access to an x86_64 box. Ok, can you post the output of this:

unzip -l \
/usr/share/eclipse/plugins/org.eclipse.swt.gtk64_3.1.0/ws/gtk/swt-cairo.jar \
| grep Cairo
Comment 7 John Ellson 2005-04-04 18:25:27 EDT
ellson@ontap:~> unzip -l \
> /usr/share/eclipse/plugins/org.eclipse.swt.gtk64_3.1.0/ws/gtk/swt-cairo.jar \
> | grep Cairo
     6854  04-03-05 23:31   org/eclipse/swt/internal/cairo/Cairo.class
Comment 8 John Ellson 2005-04-09 09:12:19 EDT
Same problem with eclipse-platform-3.1.0_fc-0.M5.18 today.

Plus I get these errors on rpm freshen.  I get the same errors for:
libswt3-gtk2, eclipse-platform, eclipse-ecj, eclipse-jdt, eclipse-pde, 
eclipse-bugzilla, eclipse-cdt, eclipse-changelog.

There is no /usr/lib64/gcj-4.0.0/classmap.db, but there is a
/usr/lib64/gcj-4.0.0/classmap.db.d/

======================example errors==================

   2:eclipse-platform       ########################################### [ 17%]
java.io.FileNotFoundException: /usr/lib64/gcj-4.0.0/classmap.db (No such file or
directory)
   at gnu.java.nio.channels.FileChannelImpl.open(java.lang.String, int)
(/usr/lib64/libgcj.so.6.0.0)
   at gnu.java.nio.channels.FileChannelImpl.FileChannelImpl(java.lang.String,
int) (/usr/lib64/libgcj.so.6.0.0)
   at java.io.FileInputStream.FileInputStream(java.io.File)
(/usr/lib64/libgcj.so.6.0.0)
   at gnu.gcj.runtime.PersistentByteMap.PersistentByteMap(java.io.File,
gnu.gcj.runtime.PersistentByteMap$AccessMode) (/usr/lib64/libgcj.so.6.0.0)
   at .__libc_start_main (/lib64/libc-2.3.4.so)
Comment 9 Mary Ellen Foster 2005-04-11 19:08:59 EDT
I get the same errors as in Comment #8 when updating my freshly installed FC4T2
against rawhide. (This may in fact be a separate bug.)

Here's the backtrace from yum:

  Updating  : libswt3-gtk2                 ##################### [ 59/227]
java.io.FileNotFoundException: /usr/lib/gcj-4.0.0/classmap.db (No such file or
directory)
   at gnu.java.nio.channels.FileChannelImpl.open(java.lang.String, int)
(/usr/lib/libgcj.so.6.0.0)
   at gnu.java.nio.channels.FileChannelImpl.FileChannelImpl(java.lang.String,
int) (/usr/lib/libgcj.so.6.0.0)
   at java.io.FileInputStream.FileInputStream(java.io.File)
(/usr/lib/libgcj.so.6.0.0)
   at gnu.gcj.runtime.PersistentByteMap.PersistentByteMap(java.io.File,
gnu.gcj.runtime.PersistentByteMap$AccessMode) (/usr/lib/libgcj.so.6.0.0)
   at gnu.java.lang.MainThread.call_main() (/usr/lib/libgcj.so.6.0.0)
   at gnu.java.lang.MainThread.run() (/usr/lib/libgcj.so.6.0.0)
error: %post(libswt3-gtk2-3.1.0_fc-0.M5.18.i386) scriptlet failed, exit status 123

Exactly the same error on updating eclipse-ecj and eclipse-platform, too. And
indeed that file doesn't exist. Here are the current contents of
/usr/lib/gcj-4.0.0/:

total 28
-rw-r--r--  1 root root    0 Apr 11 21:51 classmap.db5fs3e4
-rw-r--r--  1 root root    0 Apr 12 00:07 classmap.dbbylyfe
drwxr-xr-x  2 root root 4096 Apr 12 00:07 classmap.db.d
-rw-r--r--  1 root root    0 Apr 12 00:03 classmap.dbf1ddkj
-rw-r--r--  1 root root    0 Apr 11 21:51 classmap.dbhom6as
-rw-r--r--  1 root root    0 Apr 11 21:50 classmap.dbhtpusp
-rw-r--r--  1 root root    0 Apr 12 00:02 classmap.dbova754
-rw-r--r--  1 root root    0 Apr 12 00:06 classmap.dbp0zn1u
-rw-r--r--  1 root root    0 Apr 11 21:51 classmap.dbr30nru
-rw-r--r--  1 root root    0 Apr 11 21:51 classmap.dbtqzeyv
-rw-r--r--  1 root root    0 Apr 12 00:03 classmap.dbuohmhs
Comment 10 Andrew Overholt 2005-04-11 20:16:37 EDT
Ignoring the Eclipse-specific issues presented here, should we have a default
classmap.db, Jakub?  Should it be in the gcc RPMs?  I heard Tom mention
something about %ghost ing the file.  Does that make sense?
Comment 11 Ben Konrath 2005-04-19 15:53:29 EDT
I just tested the latest stuff from rawhide on x86_64 and they seem to work. Can
someone confirm this with a clean workspace and config directory?

% rpm -qa | grep java
java-1.4.2-gcj-compat-devel-1.4.2.0-40jpp_18rh
gcc-java-4.0.0-0.42
java-1.4.2-gcj-compat-1.4.2.0-40jpp_18rh
java-1.4.2-gcj-compat-src-1.4.2.0-40jpp_18rh

% rpm -qa | grep eclipse
eclipse-platform-3.1.0_fc-0.M6.6
eclipse-ecj-3.1.0_fc-0.M6.6
eclipse-jdt-3.1.0_fc-0.M6.6
eclipse-pde-3.1.0_fc-0.M6.6
eclipse-platform-devel-3.1.0_fc-0.M6.6
Comment 12 John Ellson 2005-04-19 16:39:45 EDT
Works for me, or at least beyond where it crashed before, to the point of
opening the tutorial screen and then the workbench.   I can't meaningfully test
further at the moment because I'm new to eclipse and this is my first time using it.
Comment 13 Andrew Overholt 2005-04-19 16:45:54 EDT
Okay, we'll close this one for now.  Please file specific x86_64 issues if/as
you find any.

Note You need to log in before you can comment on or make changes to this bug.