Bug 152394 - oops in __rb_rotate_left on 2.6.10-1.770_FC3smp)
oops in __rb_rotate_left on 2.6.10-1.770_FC3smp)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-29 02:26 EST by Götz Reinicke
Modified: 2015-01-04 17:18 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-28 04:09:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Götz Reinicke 2005-03-29 02:26:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; de-AT; rv:1.7.5) Gecko/20041217

Description of problem:
Hi,
my FC3 (Kernel 2.6.10-1.770_FC3smp) Server has nearly once a week the problem,
that it stops compleatly and the last messages are "Unable to handle kernel NULL
pointer"; e.g:

Mar 29 08:30:46 mail kernel:  <1>Unable to handle kernel NULL pointer dereference at virtual address 0000000c
Mar 29 08:30:46 mail kernel:  printing eip:
Mar 29 08:30:46 mail kernel: c01b387c
Mar 29 08:30:46 mail kernel: *pde = 0236b001
Mar 29 08:30:46 mail kernel: Oops: 0000 [#3]
Mar 29 08:30:46 mail kernel: SMP 
Mar 29 08:30:46 mail kernel: Modules linked in: iptable_filter ip_tables md5 ipv6 autofs4 i2c_dev i2c_core nfs lockd sunrpc microcode dm_mod video b
utton battery ac ohci_hcd cfi_probe gen_probe scb2_flash mtdcore chipreg map_funcs tg3 floppy sg ext3 jbd megaraid_mbox megaraid_mm sd_mod scsi_mod
Mar 29 08:30:46 mail kernel: CPU:    1
Mar 29 08:30:46 mail kernel: EIP:    0060:[<c01b387c>]    Not tainted VLI
Mar 29 08:30:46 mail kernel: EFLAGS: 00010286   (2.6.10-1.770_FC3smp) 
Mar 29 08:30:46 mail kernel: EIP is at __rb_rotate_left+0x8/0x36
Mar 29 08:30:46 mail kernel: eax: c4363780   ebx: c041e5e4   ecx: c4363780   edx: 00000000
Mar 29 08:30:46 mail kernel: esi: c4363780   edi: cc4d00c0   ebp: c041e5e4   esp: eec5ded4

Version-Release number of selected component (if applicable):
kernel-2.6.10-1.770_FC3smp

How reproducible:
Sometimes

Steps to Reproduce:
1. From time to time, the error reproduces himselfe
2. 
3.
  

Actual Results:  The system hangs.

Additional info:
Comment 1 Warren Togami 2005-03-29 02:35:25 EST
http://people.redhat.com/davej/kernels/Fedora/
Please see if the 2.6.11 based test kernel from here is any better.  It requires
the latest FC3 update udev to be installed.
Comment 2 nsteussy 2005-05-17 08:18:39 EDT
I found this oops in the log this morning.  Rather than i386 I am running
x86_64, and hope this is the right place for this notification.  I can find no
triggering event, and the computer appears to have recovered gracefully.

Nic Steussy


[root@osprey ~]# uname -a
Linux osprey.bio.purdue.edu 2.6.11-1.14_FC3 #1 Thu Apr 7 19:25:50 EDT 2005
x86_64 x86_64 x86_64 GNU/Linux



May 17 05:01:02 osprey crond(pam_unix)[2959]: session closed for user root
May 17 05:40:20 osprey kernel: Unable to handle kernel NULL pointer dereference
at 000000000000009d RIP:
May 17 05:40:20 osprey kernel: <ffffffff80163a09>{acct_update_integrals+9}
May 17 05:40:20 osprey kernel: PGD 3d46b067 PUD 3e2ff067 PMD 0
May 17 05:40:20 osprey kernel: Oops: 0000 [1]
May 17 05:40:20 osprey kernel: CPU 0
May 17 05:40:20 osprey kernel: Modules linked in: nvidia(U) nfsd exportfs md5
ipv6 parport_pc lp parport autofs4 nfs lockd sunrpc ipt_LOG ipt_limit ipt_state
ip_conntrack iptable_filter ip_tables nls_utf8 vfat fat dm_mod video button
battery ac ohci1394 ieee1394 uhci_hcd ehci_hcd i2c_viapro i2c_core snd_via82xx
snd_ac97_codec snd_pcm_oss snd_mixer_oss snd_pcm snd_timer snd_page_alloc
gameport snd_mpu401_uart snd_rawmidi snd_seq_device snd soundcore sk98lin floppy
ext3 jbd sata_via libata sd_mod scsi_mod
May 17 05:40:20 osprey kernel: Pid: 3227, comm: cpuspeed Tainted: P     
2.6.11-1.14_FC3
May 17 05:40:20 osprey kernel: RIP: 0010:[<ffffffff80163a09>]
<ffffffff80163a09>{acct_update_integrals+9}
May 17 05:40:20 osprey kernel: RSP: 0018:ffff81003a81fea0  EFLAGS: 00010206
May 17 05:40:20 osprey kernel: RAX: ffff81003d998030 RBX: 0000000000000001 RCX:
0000000000000001
May 17 05:40:20 osprey kernel: RDX: 0000000000000000 RSI: 0000000000100073 RDI:
ffff81003d9e2640
May 17 05:40:20 osprey kernel: RBP: 0000000000001000 R08: 0000000000000000 R09:
0000000000000000
May 17 05:40:20 osprey kernel: R10: ffff81003cf48190 R11: ffff81003cf48d28 R12:
0000000000000000
May 17 05:40:20 osprey kernel: R13: 00002aaaaaaac000 R14: 0000000000100073 R15:
ffff81003d9e2640
May 17 05:40:20 osprey kernel: FS:  00002aaaaaad2b00(0000)
GS:ffffffff80550700(0000) knlGS:000000005557cae0
May 17 05:40:20 osprey kernel: CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
May 17 05:40:20 osprey kernel: CR2: 000000000000009d CR3: 000000003d412000 CR4:
00000000000006e0
May 17 05:40:20 osprey kernel: Process cpuspeed (pid: 3227, threadinfo
ffff81003a81e000, task ffff81003d998030)
May 17 05:40:20 osprey kernel: Stack: ffffffff80185621 0000000000000000
00000002aaaaaaac 0000000000000000
May 17 05:40:20 osprey kernel:        0000000000000000 0000000000000001
0000000100000000 0010007300000000
May 17 05:40:20 osprey kernel:        0000000000000000 00000002aaaaaaac
May 17 05:40:20 osprey kernel: Call Trace:<ffffffff80185621>{do_mmap_pgoff+1793}
<ffffffff80115b83>{sys_mmap+179}
May 17 05:40:20 osprey kernel:        <ffffffff8010ec0a>{system_call+126}
May 17 05:40:20 osprey kernel:
May 17 05:40:20 osprey kernel: Code: 48 8b 8a b8 00 00 00 48 85 c9 74 3e 48 8b
82 98 02 00 00 48
May 17 05:40:20 osprey kernel: RIP <ffffffff80163a09>{acct_update_integrals+9}
RSP <ffff81003a81fea0>
May 17 05:40:20 osprey kernel: CR2: 000000000000009d
May 17 06:01:01 osprey crond(pam_unix)[2973]: session opened for user root by
(uid=0)
Comment 3 Dave Jones 2005-05-17 21:43:32 EDT
Nic, completely unrelated trace to this bug.
You also have the binary nvidia module loaded, which makes your problem
impossible to diagnose.
Comment 4 Dave Jones 2005-07-15 16:05:00 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.