Bug 152395 - Yum stops updating from a channel when trying a wrongly configured mirror
Summary: Yum stops updating from a channel when trying a wrongly configured mirror
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: yum   
(Show other bugs)
Version: 3
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL: ftp://klid.dk/pub/fedora/linux/core/
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-29 07:48 UTC by Dennis Wagelaar
Modified: 2014-01-21 22:51 UTC (History)
1 user (show)

Fixed In Version: 2.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-22 17:36:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dennis Wagelaar 2005-03-29 07:48:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
When yum chooses the "klid.dk" mirror for downloading fedora updates, the mirror gives an error (530 too many users/only for Denmark in case of ftp, or 450 Forbidden in case of http). Yum doesn't try another mirror and just continues to the next channel.

Version-Release number of selected component (if applicable):
yum-2.2.0-0.fc3

How reproducible:
Sometimes

Steps to Reproduce:
1. Run "yum update"
2.
3.
  

Actual Results:  If yum tries a mirror that gives an error, it stops trying for that channel

Expected Results:  Yum should have tried another mirror, since the current mirror doesn't provide service.

Additional info:

Comment 1 Jeremy Katz 2005-09-21 19:25:41 UTC
Does this still occur with the current version of yum (2.4.0)?

Comment 2 Dennis Wagelaar 2005-09-22 11:50:59 UTC
No, this issue is fixed in my yum: yum-2.4.0-0.fc4


Note You need to log in before you can comment on or make changes to this bug.