Bug 15241 - Unable to compile kernel
Summary: Unable to compile kernel
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-03 15:27 UTC by Need Real Name
Modified: 2008-08-01 16:22 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-05 21:10:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-08-03 15:27:03 UTC
Installing pinstripe toasted my modules.conf, presumably because it
installed a new kernel. This is okay, I kinda expected it. However, when I
went to recompile the kernel (2.2.16 from ftp.kernel.org), it failed with
all sorts of nasty errors while in the Assembler Pre-processor stage, on
the file checksum.c. When I uninstalled the gcc (and associated) rpms and
re-installed the RH6.2 egcs rpms, everything worked fine.

	HTH

	W

Comment 1 Brian J. Conway 2000-08-03 15:41:26 UTC
You need to install the kgcc package and then edit the kernel makefile to use
kgcc instead of the provided gcc when you compile.  My question is why is a gcc
compiler included that won't compile a kernel?  Why not use 2.95 and have it
work all around?

Comment 2 Alan Cox 2000-08-05 21:09:59 UTC
2.95 is not a recommended compiler for the 2.2 kernel. These arent compiler
problems but kernel assumptions about optimisations. 2.95 is believed to build
the very latest 2.2.17pre releases completely correctly but thats not the same
thing as a trusted build for a production site


Comment 3 Alan Cox 2000-08-05 21:10:24 UTC
2.95 is not a recommended compiler for the 2.2 kernel. These arent compiler
problems but kernel assumptions about optimisations. 2.95 is believed to build
the very latest 2.2.17pre releases completely correctly but thats not the same
thing as a trusted build for a production site



Note You need to log in before you can comment on or make changes to this bug.