Bug 152482 - incomplete dependencies break pkgconfig dependency chain
incomplete dependencies break pkgconfig dependency chain
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution-data-server (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-29 16:27 EST by Michael Schwendt
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: evolution-data-server-1.9.5-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-09 14:29:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch against CVS (369 bytes, patch)
2005-04-12 20:21 EDT, Michael Schwendt
no flags Details | Diff

  None (edit)
Description Michael Schwendt 2005-03-29 16:27:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.6) Gecko/20050323
Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
Package contains a pkgconfig template file, which lists other pkgconfig files as
requirements. When these files are included in other RPM packages, the RPM
package "Requires" must be complete. Else pkgconfig fails, prints an error
message and returns an error code for standard queries like "pkg-config --exists
foo-1.0", "pkg-config --cflags foo-1.0" or "pkg-config --list-all".

Missing dependencies due to pkgconfig files:

Requires: libsoup-devel



Version-Release number of selected component (if applicable):
evolution-data-server-devel-1.2.0-2

How reproducible:
Always

Steps to Reproduce:
-
    

Additional info:
Comment 1 Michael Schwendt 2005-04-12 20:21:16 EDT
Created attachment 113068 [details]
patch against CVS
Comment 2 Scott Tsai 2005-08-09 12:51:44 EDT
I can confirm this bug is still present on FC4 as of
evolution-data-server-devel-1.2.3-1.fc4
Comment 3 Dave Malcolm 2007-01-08 09:54:35 EST
Thanks for filing this bug report, and investigating it.  I'm sorry that it has
gone for so long without activity.

Reassigning to mbarnes.
Comment 4 Matthew Barnes 2007-01-09 14:29:17 EST
Fixed in evolution-data-server-1.9.5-2.fc7.

Note You need to log in before you can comment on or make changes to this bug.