Bug 152483 - incomplete dependencies break pkgconfig dependency chain
incomplete dependencies break pkgconfig dependency chain
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: epiphany (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-29 16:28 EST by Michael Schwendt
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version: 2.16.2-1.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-22 06:59:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch against CVS (557 bytes, patch)
2005-04-12 20:23 EDT, Michael Schwendt
no flags Details | Diff

  None (edit)
Description Michael Schwendt 2005-03-29 16:28:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.6) Gecko/20050323
Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
Package contains a pkgconfig template file, which lists other pkgconfig files as
requirements. When these files are included in other RPM packages, the RPM
package "Requires" must be complete. Else pkgconfig fails, prints an error
message and returns an error code for standard queries like "pkg-config --exists
foo-1.0", "pkg-config --cflags foo-1.0" or "pkg-config --list-all".

missing dependencies due to pkgconfig files:

Requires: ORBit2-devel
Requires: libglade2-devel
Requires: libgnomeui-devel
Requires: gtk2-devel
Requires: gnome-vfs2-devel
Requires: libxml2-devel
Requires: libbonobo-devel
Requires: GConf2-devel


Version-Release number of selected component (if applicable):
epiphany-devel-1.5.8-3

How reproducible:
Always

Steps to Reproduce:
-

Additional info:
Comment 1 Michael Schwendt 2005-04-12 20:23:22 EDT
Created attachment 113070 [details]
patch against CVS
Comment 2 Christian Iseli 2007-01-22 06:08:15 EST
This report targets the FC3 or FC4 products, which have now been EOL'd.

Could you please check that it still applies to a current Fedora release, and
either update the target product or close it ?

Thanks.
Comment 3 Michael Schwendt 2007-01-22 06:59:22 EST
Some are still missing, but it is beyond my time to track issues
for so many months. Here's the Requires which ought to be mapped
to direct RPM Requires in epiphany-devel:

$ grep Req epiphany-2.16.pc 
Requires: gtk+-2.0, libxml-2.0, libgnomeui-2.0, bonobo-activation-2.0,
ORBit-2.0, libglade-2.0, gnome-vfs-2.0, gnome-vfs-module-2.0, gconf-2.0

However, in FC6 the depchain pulls in all needed -devel packages via
other -devel packages' dependencies, hence I close this ticket.

Note You need to log in before you can comment on or make changes to this bug.