Bug 152484 - incomplete dependencies break pkgconfig dependency chain
incomplete dependencies break pkgconfig dependency chain
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-29 16:28 EST by Michael Schwendt
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: evolution-2.8.2.1-2.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-09 13:38:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch against CVS (451 bytes, patch)
2005-04-12 20:16 EDT, Michael Schwendt
no flags Details | Diff

  None (edit)
Description Michael Schwendt 2005-03-29 16:28:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.6) Gecko/20050323
Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
Package contains a pkgconfig template file, which lists other pkgconfig files as
requirements. When these files are included in other RPM packages, the RPM
package "Requires" must be complete. Else pkgconfig fails, prints an error
message and returns an error code for standard queries like "pkg-config --exists
foo-1.0", "pkg-config --cflags foo-1.0" or "pkg-config --list-all".

missing dependencies due to pkgconfig files:

Requires: evolution-data-server-devel


Version-Release number of selected component (if applicable):
evolution-devel-2.2.0-5

How reproducible:
Always

Steps to Reproduce:
-    

Additional info:
Comment 1 Michael Schwendt 2005-04-12 20:16:45 EDT
Created attachment 113066 [details]
patch against CVS
Comment 2 Dave Malcolm 2007-01-08 09:55:35 EST
Thanks for filing this bug report, and investigating it.  I'm sorry that it has
gone for so long without activity; it was incorrectly assigned to me.

Reassigning to mbarnes; once again, my apologies for my lack of activity on this
bug.
Comment 3 Matthew Barnes 2007-01-09 13:38:50 EST
Thanks for the patch.  This seems to have been fixed already.

Note You need to log in before you can comment on or make changes to this bug.