Bug 152491 - incomplete dependencies break pkgconfig dependency chain
incomplete dependencies break pkgconfig dependency chain
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-utils (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-29 16:39 EST by Michael Schwendt
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-13 00:28:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2005-03-29 16:39:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.6) Gecko/20050323
Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
Without splitting off a -devel package, it's not possible to fix this.

Package gnome-utils contains a pkgconfig template file, which lists other
pkgconfig files as requirements. When these files are included in other RPM
packages, the RPM package "Requires" must be complete. Else pkgconfig fails,
prints an error message and returns an error code for standard queries like
"pkg-config --exists foo-1.0", "pkg-config --cflags foo-1.0" or "pkg-config
--list-all".

Missing dependencies due to pkgconfig files:

Requires: glib2-devel
Requires: libgnome-devel
Requires: libgnomeui-devel
Requires: gtk2-devel


Version-Release number of selected component (if applicable):
gnome-utils-2.9.92-3

How reproducible:
Always

Steps to Reproduce:
-


Additional info:
Comment 1 Warren Togami 2005-03-30 05:06:04 EST
Can't this be simplified to just one or two?  Because gtk2-devel pulls in
glib2-devel already?
Comment 2 Michael Schwendt 2005-03-30 05:17:40 EST
Yes, elimination of redundancy is possible.
Comment 3 Matthias Clasen 2005-10-13 00:28:08 EDT
Will be fixed in the next build

Note You need to log in before you can comment on or make changes to this bug.