Bug 152493 - incomplete dependencies break pkgconfig dependency chain
Summary: incomplete dependencies break pkgconfig dependency chain
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-mag   
(Show other bugs)
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-29 21:40 UTC by Michael Schwendt
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-30 14:28:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Schwendt 2005-03-29 21:40:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.6) Gecko/20050323
Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
Package gnome-mag-devel contains a pkgconfig template file, which lists other
pkgconfig files as requirements. When these files are included in other RPM
packages, the RPM package "Requires" must be complete. Else pkgconfig fails,
prints an error message and returns an error code for standard queries like
"pkg-config --exists foo-1.0", "pkg-config --cflags foo-1.0" or "pkg-config
--list-all".

missing dependencies due to pkgconfig files:

Requires: gtk2-devel


Version-Release number of selected component (if applicable):
gnome-mag-devel-0.11.14-2

How reproducible:
Always

Steps to Reproduce:
-    

Additional info:


Note You need to log in before you can comment on or make changes to this bug.