Bug 152495 - icu: test suite failures with gcc4
icu: test suite failures with gcc4
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
http://bugs.icu-project.org/cgibin/ic...
:
Depends On:
Blocks: 164493
  Show dependency treegraph
 
Reported: 2005-03-29 16:48 EST by Ville Skyttä
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-13 12:24:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2005-03-29 16:48:21 EST
icu-3.2-1 fails its test suite when rebuilt with gcc4 in devel.

http://fedoraproject.org/extras/development/build-logs/ppc/icu-3.2-1.log
(Not PPC specific, happens on i386 too.)
Comment 1 Ville Skyttä 2005-04-24 16:09:22 EDT
Reported upstream: http://bugs.icu-project.org/cgibin/icu-bugs?findid=4489
Comment 2 Ville Skyttä 2005-04-28 18:17:53 EDT
Upstream suspects a gcc4 issue, so moving to the gcc component.

Summary: icu from Extras builds fine with gcc4, but running the test suite (done
in the Extras package) produces many errors and a few core dumps.  icu builds
fine and passes its test suite with compat-gcc-32* on devel, as well as gcc 3.4
on FC-3.  See upstream report URL in comment 1 for more info.
Comment 3 Michael Schwendt 2005-07-28 11:19:49 EDT
Gave a rebuild a try (when bug 164507 came in). Results with gcc-4.0.1-4.fc4:

   ---OK:   NewResourceBundleTest
      ---OK:   testMaxMin
      ---OK:   testNaN
         FAIL: isInfinite(+Infinity) returned FALSE, should be TRUE.
         FAIL: isPositiveInfinity(+Infinity) returned FALSE, should be TRUE.
      
      ---ERRORS (2) in testPositiveInfinity
      
         FAIL: isInfinite(-Infinity) returned FALSE, should be TRUE.
         FAIL: isNegativeInfinity(-Infinity) returned FALSE, should be TRUE.
      
      ---ERRORS (2) in testNegativeInfinity
      
         FAIL: isInfinite(1/0.0) returned FALSE, should be TRUE.
         FAIL: isInfinite(1/-0.0) returned FALSE, should be TRUE.
         FAIL: isPositiveInfinity(1/0.0) returned FALSE, should be TRUE.
         FAIL: isNegativeInfinity(1/-0.0) returned FALSE, should be TRUE.
      
      ---ERRORS (4) in testZero
      
   
   ---ERRORS (8) in PUtilTest
   


   ---OK:   IntlTestDateFormat
/bin/sh: line 1: 32727 Segmentation fault     
LD_LIBRARY_PATH=../../lib:../../stubdata:../../tools/ctestfw:$LD_LIBRARY_PATH
./intltest
make[2]: Leaving directory `/home/misc/tmp/rpm/BUILD/icu/source/test/intltest'


 /putiltst/
   ERROR: uprv_isNegativeInfinity failed.
   ERROR: uprv_isPositiveInfinity failed.
   ERROR: uprv_isInfinite failed.
   ---[3 ERRORS]  ---/putiltst/TestPUtilAPI 
   ---[OK]  ---/putiltst/TestErrorName 


SUMMARY:
******* [Total error count:	3]
 Errors in
   [/putiltst/TestPUtilAPI]
make[2]: *** [check-local] Error 1
Comment 4 Ville Skyttä 2005-07-31 10:47:05 EDT
Yep, those look like the errors I saw, too.  And FWIW, the seemingly same ones 
seem to occur with icu 3.4.d02 (3.4 release candidate).  
Comment 5 Ville Skyttä 2005-08-02 06:53:11 EDT
Ditto with 3.4 final. 
Comment 6 Thorsten Leemhuis 2005-09-13 12:24:26 EDT
icu builds fine under gcc4 with
>export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"

Updated version for FC4 build (and mail-notification also). Will remove devel
branch because icu is in rawhide now.

Note You need to log in before you can comment on or make changes to this bug.