Bug 152499 - incomplete dependencies break pkgconfig dependency chain
incomplete dependencies break pkgconfig dependency chain
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libgail-gnome (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-29 16:52 EST by Michael Schwendt
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-30 10:08:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2005-03-29 16:52:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.6) Gecko/20050323
Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
Without splitting off a -devel package, it's not possible to fix this.

Package libgail-gnome contains a pkgconfig template file, which lists other
pkgconfig files as requirements. When these files are included in other RPM
packages, the RPM package "Requires" must be complete. Else pkgconfig fails,
prints an error message and returns an error code for standard queries like
"pkg-config --exists foo-1.0", "pkg-config --cflags foo-1.0" or "pkg-config
--list-all".

Additionally, "gnomeui.pc" is not found in any Fedora Core 4 Test 1 package.

missing dependencies due to pkgconfig files:

Requires: atk-devel
Requires: libbonoboui-devel
Requires: gtk2-devel
NOT FOUND: gnomeui.pc


Version-Release number of selected component (if applicable):
libgail-gnome-1.1.0-3

How reproducible:
Always

Steps to Reproduce:
-

Additional info:

Note You need to log in before you can comment on or make changes to this bug.