Bug 152506 - incomplete dependencies break pkgconfig dependency chain
incomplete dependencies break pkgconfig dependency chain
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-29 17:02 EST by Michael Schwendt
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: NetworkManager-0.6.4-5.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-27 00:14:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2005-03-29 17:02:13 EST
Without splitting off a -devel package or deleting the .pc file, it's
not possible to fix this.

Package NetworkManager-glib contains a pkgconfig template file, which
lists other pkgconfig files as requirements. When these files are
included in other RPM packages, the RPM package "Requires" must be
complete. Else pkgconfig fails, prints an error message and returns an
error code for standard queries like "pkg-config --exists foo-1.0",
"pkg-config --cflags foo-1.0" or "pkg-config --list-all".

NetworkManager-glib-0.4-1.cvs20050307.3.0.i386.rpm

missing dependencies due to pkgconfig files:

Requires: glib2-devel
Requires: dbus-devel
Comment 1 Matthias Clasen 2006-11-27 00:14:22 EST
This is fixed in FC6/FC7, as far as I can see.

Note You need to log in before you can comment on or make changes to this bug.