Bug 152507 - incomplete dependencies break pkgconfig dependency chain
incomplete dependencies break pkgconfig dependency chain
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openhpi (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-29 17:02 EST by Michael Schwendt
Modified: 2015-03-04 20:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-30 06:39:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2005-03-29 17:02:41 EST
Without splitting off a -devel package or deleting the .pc file, it's
not possible to fix this.

Package openhpi contains a pkgconfig template file, which lists other
pkgconfig files as requirements. When these files are included in
other RPM packages, the RPM package "Requires" must be complete. Else
pkgconfig fails, prints an error message and returns an error code for
standard queries like "pkg-config --exists foo-1.0", "pkg-config
--cflags foo-1.0" or "pkg-config --list-all".

openhpi-1.9.2-3.i386.rpm

missing dependencies due to pkgconfig files:

Requires: glib2-devel
Requires: glib-devel
Comment 1 Phil Knirsch 2005-03-30 06:39:14 EST
Moved .pc files to -devel package, hope thats all you asked for. ;)

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.