Bug 152515 - /usr/lib/libxml2.la is not installed anymore
/usr/lib/libxml2.la is not installed anymore
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libxml2 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-29 17:35 EST by John (J5) Palmieri
Modified: 2013-03-13 00:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-30 05:13:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John (J5) Palmieri 2005-03-29 17:35:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050322 Epiphany/1.5.8

Description of problem:
From the spec file:
* Mon Mar 14 2005 Daniel Veillard <veillard@redhat.com> 2.6.18-2
-removing the .la

A number of my packages look for the .la file to link against.  The most recent failure has been totem.  Below is the relevant output.

/bin/sh ../libtool --mode=link gcc  -Wall       -Wchar-subscripts -Wmissing-declarations -Wmissing-prototypes   -Wnested-externs -Wpointer-arith        -Wcast-align -Wsign-compare     -fno-strict-aliasing    -I/usr/X11R6/include -O2 -Wall -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -m32 -march=i386 -mtune=pentium4   -o totem-video-thumbnailer  totem-video-thumbnailer.o -L/usr/X11R6/lib -lX11 -Wl,--export-dynamic -pthread -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lpangoxft-1.0 -lpangox-1.0 -lpango-1.0 -lgstgconf-0.8 -lgconf-2 -lORBit-2 -lgstinterfaces-0.8 -lgstreamer-0.8 -lgobject-2.0 -lgmodule-2.0 -ldl -lxml2 -lpthread -lz -lm -lgthread-2.0 -lglib-2.0   -lX11 -lXtst -L/usr/X11R6/lib -lXxf86vm -lX11 -lXrandr -lXrender  -Wl,--export-dynamic -pthread -L/usr/X11R6/lib -lglade-2.0 -lgnome-desktop-2 -lgnomeui-2 -lSM -lICE -lstartup-notification-1 -lbonoboui-2 -lgnomecanvas-2 -lgnome-2 -lpopt -lart_lgpl_2 -lpangoft2-1.0 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lpangoxft-1.0 -lpangox-1.0 -lpango-1.0 -lgnomevfs-2 -lbonobo-2 -lbonobo-activation -lgstgconf-0.8 -lgconf-2 -lORBit-2 -lgstinterfaces-0.8 -lgstreamer-0.8 -lgobject-2.0 -lgmodule-2.0 -ldl -lgthread-2.0 -lxml2 -lpthread -lz -lm -lglib-2.0   -lnautilus-burn -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm -lpangoxft-1.0 -lpangox-1.0 -lpango-1.0 -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0   libbaconvideowidget.la -L/usr/X11R6/lib
/bin/sh ../libtool --mode=link gcc  -Wall       -Wchar-subscripts -Wmissing-declarations -Wmissing-prototypes   -Wnested-externs -Wpointer-arith        -Wcast-align -Wsign-compare     -fno-strict-aliasing    -I/usr/X11R6/include -O2 -Wall -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -m32 -march=i386 -mtune=pentium4   -o bvw-test  bvw-test.o -L/usr/X11R6/lib -lX11 -Wl,--export-dynamic -pthread -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lpangoxft-1.0 -lpangox-1.0 -lpango-1.0 -lgstgconf-0.8 -lgconf-2 -lORBit-2 -lgstinterfaces-0.8 -lgstreamer-0.8 -lgobject-2.0 -lgmodule-2.0 -ldl -lxml2 -lpthread -lz -lm -lgthread-2.0 -lglib-2.0   -lX11 -lXtst -L/usr/X11R6/lib -lXxf86vm -lX11 -lXrandr -lXrender  libbaconvideowidget.la -L/usr/X11R6/lib

libtool: link: cannot find the library `/usr/lib/libxml2.la'
make[3]: *** [totem-video-thumbnailer] Error 1



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Compile totem package
  

Actual Results:  libtool: link: cannot find the library `/usr/lib/libxml2.la' error

Expected Results:  Totem compiles and is packaged

Additional info:
Comment 1 John (J5) Palmieri 2005-03-29 18:01:48 EST
Found out this is due to linking with gnome-vfs2 which depends on libxm2.la in
its .la file.  Davidz is going to recompile which should clear up my problem. 
You might want to post to fedora-maintainers-list to notify anyone else about
how the change may effect other packages.
Comment 2 Daniel Veillard 2005-03-30 05:13:54 EST
Okay, then NOTABUG !

Daniel

Note You need to log in before you can comment on or make changes to this bug.