This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 152529 - Missing dependency installing Gnotime
Missing dependency installing Gnotime
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnotime (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Toshio Kuratomi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-29 20:34 EST by Zuirdj
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.2.1-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-05 18:46:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zuirdj 2005-03-29 20:34:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050328 Firefox/1.0.2 Fedora/1.0.2-3

Description of problem:
Trying to install Gnotime, yum shows missing dependency (libgtkhtml-3.1.so.11) .

[root@pc-149-16-83-200 zuirdj]# yum install gnotime
Setting up Install Process
Setting up Repos
development               100% |=========================| 1.1 kB    00:00
extras-dev                100% |=========================|  951 B    00:00
livna-stable              100% |=========================|  951 B    00:00
livna-unstable            100% |=========================|  951 B    00:00
livna-testing             100% |=========================|  951 B    00:00
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package gnotime.i386 0:2.2.1-5 set to be updated
--> Running transaction check
--> Processing Dependency: libqof-0.5.0.so.1 for package: gnotime
--> Processing Dependency: libguile-ltdl.so.1 for package: gnotime
--> Processing Dependency: libguile.so.12 for package: gnotime
--> Processing Dependency: libqofsql-0.5.0.so.1 for package: gnotime
--> Processing Dependency: libgtkhtml-3.1.so.11 for package: gnotime
--> Processing Dependency: libqthreads.so.12 for package: gnotime
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package qof.i386 0:0.5.0-5 set to be updated
---> Package guile.i386 5:1.6.7-2 set to be updated
--> Running transaction check
--> Processing Dependency: libgtkhtml-3.1.so.11 for package: gnotime
--> Processing Dependency: slib >= 3a1-1 for package: guile
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package slib.noarch 0:3a1-2 set to be updated
--> Running transaction check
--> Processing Dependency: libgtkhtml-3.1.so.11 for package: gnotime
--> Finished Dependency Resolution
Error: Missing Dependency: libgtkhtml-3.1.so.11 is needed by package gnotime

Version-Release number of selected component (if applicable):
gnotime.i386 0:2.2.1-5

How reproducible:
Always

Steps to Reproduce:
1. Add Fedora Extras Development in yum.repos
2. yum install gnotime
3. gnotime not installed
  

Additional info:
Comment 1 Toshio Kuratomi 2005-03-30 23:00:22 EST
The short summary is gnotime hasn't been rebuilt yet for FC4.  Since gtkhtml3 is
a moving target, the FC3 version isn't able to link against the FC4 version.

The longer version is that gtkhtml3 went from 3.0 to 3.1 a few Core releases
ago.  Now it's going to 3.6.  So the gnotime configure.in has to be updated to
reflect the new pkgconfig filename.  I've just added something that should work
but I haven't tested it yet.

If you could test gnotime-2.2.1-7 once its made its way through the buildsystem
that would be appreciated.
Comment 2 Zuirdj 2005-04-05 17:46:48 EDT
With latest update (gnotime-2.2.1-7) there's no more dependency problem. Gnotime
was successful installed. You can close the bug.
Comment 3 Toshio Kuratomi 2005-04-05 18:46:39 EDT
Great.  Thanks for the testing!

Note You need to log in before you can comment on or make changes to this bug.