Bug 1525382 - create project validates quota usage against the current project
Summary: create project validates quota usage against the current project
Keywords:
Status: CLOSED DUPLICATE of bug 1522705
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon
Version: 10.0 (Newton)
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Radomir Dopieralski
QA Contact: Ido Ovadia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-13 09:02 UTC by Meiyan Zheng
Modified: 2017-12-13 09:43 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-13 09:43:28 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Meiyan Zheng 2017-12-13 09:02:01 UTC
Description of problem:

Create new project and edit quota failed with below error:

Quota value(s) cannot be less than the current usage value(s):
131072RAM(MB) used. 11 instance used. 52 VCPUs used.

This issue is reported in upstream: 
https://bugs.launchpad.net/horizon/+bug/1380701

And also reported on Juno version:
https://bugzilla.redhat.com/show_bug.cgi?id=1198564


Version-Release number of selected component (if applicable):
- RHOSP 10
- python-django-horizon-10.0.2-1.el7ost.noarch                



How reproducible:


Steps to Reproduce:
1. Create new project in admin portal with identity --> project
2. Edit project and set quota 
3. 

Actual results:
Edit project quota failed with error"Quota value(s) cannot be less than the current usage value(s):..."

Expected results:
Edit project quota should be succeed without error. 

Additional info:

Comment 1 Radomir Dopieralski 2017-12-13 09:43:28 UTC

*** This bug has been marked as a duplicate of bug 1522705 ***


Note You need to log in before you can comment on or make changes to this bug.