Bug 152558 - addrtype supported by kernel but not by iptables
addrtype supported by kernel but not by iptables
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: glibc-kernheaders (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Woodhouse
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-30 07:19 EST by Ralf Spenneberg
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2007-0318
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 19:06:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Spenneberg 2005-03-30 07:19:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040922 Galeon/1.3.19

Description of problem:
The kernel-2.6.9-5.EL supports the netfilter addrtype feature
while the iptables command does not. 
Calling 
iptables -m addrtype -h 
results in an error not finding the appropiate library.




Version-Release number of selected component (if applicable):
iptables-1.2.11-3.1.RHEL4

How reproducible:
Always

Steps to Reproduce:
1. iptables -m addrtype -h
2.
3.
  

Actual Results:  iptables v1.2.11: Couldn't load match addrtype:/lib/iptables/libipt_addrtype.so: cannot open shared object file: No such file or directory

Expected Results:  Since it is enabled in the kernel I would iptables expect to know it too.

Additional info:
Comment 1 Thomas Woerner 2005-11-18 07:09:57 EST
This has to get fixed in glibc-kernheaders - there is no ipt_addrtype.h.
Comment 2 David Woodhouse 2006-09-12 11:34:16 EDT
This is fixed in glibc-kernheaders-2_4-9_1_99_EL

We'll need to get that into the buildroot and build a new iptables.
Comment 6 Jay Turner 2006-10-03 13:31:54 EDT
QE ack for 4.5.
Comment 14 Red Hat Bugzilla 2007-05-01 19:06:08 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0318.html

Note You need to log in before you can comment on or make changes to this bug.