Bug 152588 - mrproject file crashes mrproject
mrproject file crashes mrproject
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: mrproject (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
: 141741 146426 (view as bug list)
Depends On:
Blocks: 168424
  Show dependency treegraph
 
Reported: 2005-03-30 10:17 EST by Joshua Jensen
Modified: 2007-11-30 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version: RHBA-2006-0039
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-15 10:36:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The "bad" project file that mrproject creates, but then can't open (670 bytes, application/octet-stream)
2005-03-30 10:17 EST, Joshua Jensen
no flags Details

  None (edit)
Description Joshua Jensen 2005-03-30 10:17:45 EST
Description of problem:

See the attached mrproject file... it crashes mrproject immediately upon loading
the file.  Strange as I just used mrproject to create the file not but a few
seconds earlier.

Version-Release number of selected component (if applicable):

RHEL3 with all updates,  mrproject-0.9-7
Comment 1 Joshua Jensen 2005-03-30 10:17:45 EST
Created attachment 112456 [details]
The "bad" project file that mrproject creates, but then can't open
Comment 2 Joshua Jensen 2005-03-31 11:11:58 EST
Experimenting with the app today reveals that whenever:

1. a task name is indented using teh indent icon.
2. the file is save
3. the app will crash when it tries to open the saved file.

Hope this helps
Comment 3 Dan Williams 2005-03-31 11:35:37 EST
It quite possibly will.  Thanks!
Comment 4 Dan Williams 2005-05-05 15:38:23 EDT
I am indeed looking at this, but it seems libxml is somehow involved as well
which complicates things just a bit.
Comment 5 Joshua Jensen 2005-05-05 16:01:11 EDT
MrProject from FC1 solves the crashing in this case.  Can we get an
upgrade/update for RHEL3?
Comment 6 Dan Williams 2005-05-05 16:07:17 EDT
Hmmm, we don't generally upgrade the version (only backport fixes), but I'll
investigate with PM.

Are you saying you installed the FC1 RPM (mrproject-0.10-1) and it works fine?
Comment 7 Joshua Jensen 2005-05-05 16:16:48 EDT
Yes, that is what I'm saying.  
Comment 8 Dan Williams 2005-05-05 17:02:21 EDT
donald: would this be an acceptable fix for this issue?  (ie, update RHEL3
mrproject to the FC1 version of mrproject)
Comment 9 Dan Williams 2005-05-06 09:52:58 EDT
joshua: I assume you also had to install the FC1 "libmrproject" RPMs?
Comment 10 Joshua Jensen 2005-05-06 14:02:25 EDT
Yes, that too.
Comment 11 Dan Williams 2005-05-17 12:58:08 EDT
I have isolated the fix and will post testing RHEL3 RPMs soon for i386.
Comment 12 Dan Williams 2005-05-17 13:14:34 EDT
Please grab testing RPMs from http://people.redhat.com/dcbw/mrproject/ and
verify that they fix the problem.
Comment 15 Joshua Jensen 2005-05-17 14:26:02 EDT
Yup... this fixes it.  Can this come out as a streaming errata, unstead of
waiting for a U# update?
Comment 16 Dan Williams 2005-05-17 14:43:04 EDT
I can invesitgate an asynchronous update, but can't promise anything of course...
Comment 19 Dan Williams 2005-05-24 09:57:45 EDT
Unfortunately, this issue doesn't meet the criteria for an asynchronous update,
but an errata request has been filed and should get out with Update 6.
Comment 22 Dan Williams 2005-06-28 12:48:31 EDT
devel ack
Comment 32 Caolan McNamara 2005-12-05 05:36:31 EST
*** Bug 146426 has been marked as a duplicate of this bug. ***
Comment 33 Caolan McNamara 2005-12-14 04:25:58 EST
*** Bug 141741 has been marked as a duplicate of this bug. ***
Comment 35 Joshua Jensen 2005-12-28 11:18:07 EST
About nine months to fix this crazy-simple bug?  Actually, the fix happened in
May.... why is it December and this is still an issue?
Comment 37 Red Hat Bugzilla 2006-03-15 10:36:18 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0039.html

Note You need to log in before you can comment on or make changes to this bug.