Bug 152592 - File "/usr/share/printconf/util/queueTree.py", line 600, in edit_button_clicked
Summary: File "/usr/share/printconf/util/queueTree.py", line 600, in edit_button_clicked
Status: CLOSED DUPLICATE of bug 154500
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer   
(Show other bugs)
Version: 3
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-30 15:57 UTC by Rick Richardson
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-12 11:36:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
printconf-tui --Xexport > xxx.xml (8.59 KB, text/plain)
2005-03-30 16:46 UTC, Rick Richardson
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 152196 None None None Never

Description Rick Richardson 2005-03-30 15:57:44 UTC
See bug 152196 which started this.  Was working until  
pnasrat@redhat.com had me run "yum".  Would like to restore
action with "Cancel" and "OK" again.

$ root system-config-printer
Traceback (most recent call last):
  File "/usr/share/printconf/util/queueTree.py", line 600, in edit_button_clicked
    if self.editQueue.editQueueDialog (iter):
  File "/usr/share/printconf/util/editQueue.py", line 452, in editQueueDialog
    self.read_driver_options ()
  File "/usr/share/printconf/util/editQueue.py", line 1013, in read_driver_options
    dict[key] = store.get_value (iter, 1)
TypeError: iter must be a GtkTreeIter

Comment 1 Tim Waugh 2005-03-30 16:08:47 UTC
Please state the version of system-config-printer you are using (rpm -q
system-config-printer), and tell me exactly what steps you take--which buttons
you press, in which order--to get this traceback.

Thanks.

Comment 2 Rick Richardson 2005-03-30 16:22:00 UTC
Click on edit a queue.
Click on "Cancel" or "OK".
Thats it.

$ rpm -q system-config-printer
package redhat-config-printer is not installed



Comment 3 Rick Richardson 2005-03-30 16:31:59 UTC
$ rpm -q system-config-printer
system-config-printer-0.6.116-1

Still same action.

Comment 4 Tim Waugh 2005-03-30 16:39:47 UTC
Please attach the output of 'printconf-tui --Xexport'.

Comment 5 Rick Richardson 2005-03-30 16:46:17 UTC
Created attachment 112461 [details]
printconf-tui --Xexport > xxx.xml

Here it is.

Comment 6 Tim Waugh 2005-03-30 16:50:04 UTC
Works for me.

Comment 7 Rick Richardson 2005-03-30 23:38:48 UTC
Nevertheless, I am running x86_64 and it is a bug.

Comment 8 Tim Waugh 2005-03-31 08:27:28 UTC
Yes, I tried on x86_64.  I cannot reproduce what you see.

What does this say?:

rpm -V system-config-printer system-config-printer-gui foomatic


Comment 9 Rick Richardson 2005-03-31 09:25:55 UTC
$ rpm -V system-config-printer system-config-printer-gui foomatic
SM?....TC c /etc/alchemist/namespace/printconf/local.adl
$

Comment 10 Tim Waugh 2005-03-31 09:37:24 UTC
Tell me again, in much more detail, what you click with the mouse starting from
the application window appearing.  Example: click on lps queue in queue tree,
click 'Edit' button, click 'Driver options' tab (which I suspect you might be
doing) [etc].


Comment 11 Rick Richardson 2005-03-31 12:12:04 UTC
Click on "Queue name" i.e. "lp".
Click on "Edit".
Now showing "Queue name".
Click on "Cancel" or "OK".
Thats it.

You can also change to Queue type, Queue options, Printer driver, or Driver
options.  But those take a further press.

Comment 12 Tim Waugh 2005-04-12 11:36:47 UTC

*** This bug has been marked as a duplicate of 154500 ***


Note You need to log in before you can comment on or make changes to this bug.