Bug 152693 - rpm doesnt update properly on rh8
rpm doesnt update properly on rh8
Status: CLOSED WONTFIX
Product: Fedora Legacy
Classification: Retired
Component: General (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Fedora Legacy Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-31 13:01 EST by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Lawrence 2005-03-30 18:24:13 EST
The rpm in legacy-utilities for rh8 seems to leave the rpm db in an inconsistent
state.

After configuring yum for fedora legacy per instructions on the download page 

[main]
cachedir=/var/cache/yum
debuglevel=2
logfile=/var/log/yum.log
pkgpolicy=newest
 
 
[base]
name=Red Hat Linux $releasever base
baseurl=http://download.fedoralegacy.org/redhat/$releasever/os/$basearch
 
[updates]
name=Red Hat Linux $releasever updates
baseurl=http://download.fedoralegacy.org/redhat/$releasever/updates/$basearch
 
[legacy-utils]
name=Fedora Legacy utilities for Red Hat Linux $releasever
baseurl=http://download.fedoralegacy.org/redhat/$releasever/legacy-utils/$basearch

This is a redhat 8.0 box :-


yum updated rpm :-

tail -100 /var/log/yum.log.2
03/18/04 02:09:20 Installed: kernel-smp.i686
03/18/04 02:09:20 Updated: rpm.i386
03/18/04 02:09:20 Updated: rpm-devel.i386
03/18/04 02:09:20 Updated: rpm-build.i386
03/18/04 02:09:20 Updated: popt.i386
03/18/04 02:09:20 Updated: slocate.i386
03/18/04 02:09:20 Updated: cvs.i386
03/18/04 02:09:20 Updated: tcpdump.i386
03/18/04 02:09:20 Updated: rpm-python.i386

yum update then wouldnt run with the following errors :-

yum update
 rpmdb: /var/lib/rpm/Packages: unsupported hash version: 8
 error: cannot open Packages index using db3 - Invalid argument (22)


I asked about it on #rpm and the response was :-

jbj_hiho> lancelan: you've straddled db-4.0.14 db-4.1.25 forward compat
boundary. see /usr/lib/rpm/rpmdb_loadcvt script.

I ran that script and it apparently updated the rpom dbs because yum worked again.

I think the rpm is meant to do something similar in the %post ...



------- Additional Comments From marcdeslauriers@videotron.ca 2004-09-18 17:29:46 ----

Red Hat Linux 8.0 support has been suspended. This bug is being closed.



------- Bug moved to this database by dkl@redhat.com 2005-03-30 18:24 -------

This bug previously known as bug 1437 at https://bugzilla.fedora.us/
https://bugzilla.fedora.us/show_bug.cgi?id=1437
Originally filed under the Fedora Legacy product and General component.

Unknown priority P2. Setting to default priority "normal".
Unknown platform PC. Setting to default platform "All".
Setting qa contact to the default for this product.
   This bug either had no qa contact or an invalid one.


Note You need to log in before you can comment on or make changes to this bug.