Bug 152718 - yum package for RHL9
yum package for RHL9
Status: CLOSED CURRENTRELEASE
Product: Fedora Legacy
Classification: Retired
Component: Package request (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Fedora Legacy Bugs
LEGACY, rh90
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-16 09:05 EDT by Jesse Keating
Modified: 2014-01-21 17:51 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Lawrence 2005-03-30 18:25:05 EST
Please QA and approve this yum package for RHL9.



------- Additional Comments From jkeating@j2solutions.net 2004-05-16 09:13:56 ----

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
 
 
Files are at:
 
http://geek.j2solutions.net/rpms/legacy/yum/9
 
4d9971c6350557cb133639909ec7d7e4b24a245e  sha1sums
518c7ffb37ef7310c016210a71d4284eba7fef9c  yum-2.0.5-2.9.legacy.noarch.rpm
dfd6ae68c9fe9547194582608b2b6bd3e7eea6f8  yum-2.0.5-2.9.legacy.src.rpm
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)
 
iD8DBQFAp7yk4v2HLvE71NURAn8aAJ9iIt83Y7amKqSHNmd9OoQSFPQtjwCfaeUK
HhZyOg1s1w0xzCW0hAowK80=
=86PG
-----END PGP SIGNATURE-----



------- Additional Comments From marcdeslauriers@videotron.ca 2004-05-20 14:08:32 ----

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
 
sha1sums are OK
spec file looks good
builds OK
installs OK
works OK.
 
Just curious: Why is the distver 2.9.legacy?
Shouldn't it be something like 0.9.1.legacy so the upgrade to FC1 will work?
 
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)
 
iD8DBQFArUfWLMAs/0C4zNoRArcrAKCNbNeaUdkWEoU3NkdrIdPgAgXMnACfW97R
aZM2zsH8B2YT93gPBz5eOBU=
=dl+s
-----END PGP SIGNATURE-----




------- Additional Comments From cra@wpi.edu 2004-05-30 11:40:29 ----

Minor nits:

yum.conf [updates-testing] should be changed to reflect Red Hat instead of
Fedora Core.

GPG public keys should be included in docdir as in other releases.

/usr/share/yum directory should be owned by package.




------- Additional Comments From skvidal@phy.duke.edu 2004-06-09 18:28:21 ----

in response to comment #2
the current version in fc1 is 2.0.6 - so no matter the release number it will
ugprade.

add %dir %{_datadir}/yum to %files in the specfile to fix the lack of ownership
on dir mentioned in comment 3.

I checked the package and conf file and I concur with the comments in #3
s/Fedora Core/Red Hat Linux/ and I think you'll be ready to go.

You might consider removing those references to patches for yum that aren't
needed anymore.




------- Additional Comments From marcdeslauriers@videotron.ca 2004-06-11 14:03:48 ----

In response to comment #4:

It looks to me like the current version in FC1 is yum-2.0.5-1.noarch.rpm:
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/1/i386/

It won't update properly...

Where did you see 2.0.6?




------- Additional Comments From skvidal@phy.duke.edu 2004-06-11 18:28:29 ----

apparently in my crack-laced dreams.

sorry, you're right.





------- Additional Comments From marcdeslauriers@videotron.ca 2004-06-12 13:09:52 ----

Does this have to be built on a freshly-installed rh9 with no updates?




------- Additional Comments From marcdeslauriers@videotron.ca 2004-06-12 13:11:25 ----

argh...stupid question...it's in python...



------- Additional Comments From marcdeslauriers@videotron.ca 2004-06-12 14:09:37 ----

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Here are updated packages:

Changelog:
* Sat Jun 12 2004 Marc Deslauriers <marcdeslauriers@videotron.ca> 2.0.5-0.9.1.legacy
- - Changed distver to upgrade cleanly to FC1
- - Added GPG public keys
- - Removed Fedora Core reference in yum.conf.legacy file
- - Fixed ownership on yum dir

adab22e31eb0b6351f040a99256d025f0b165100  yum-2.0.5-0.9.1.legacy.noarch.rpm
569c26820cff751fa57772f0b2f67f7af8ed6519  yum-2.0.5-0.9.1.legacy.src.rpm

http://www.infostrategique.com/linuxrpms/legacy/9/yum-2.0.5-0.9.1.legacy.noarch.rpm
http://www.infostrategique.com/linuxrpms/legacy/9/yum-2.0.5-0.9.1.legacy.src.rpm

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQFAy5sdLMAs/0C4zNoRAmu2AJ93dWin8d1KcroA785S3x0hSrCiEACfRTq/
n0+szhPtHX40JVbk+8K5muE=
=aY6/
-----END PGP SIGNATURE-----




------- Additional Comments From cra@wpi.edu 2004-10-02 19:00:37 ----

Created an attachment (id=870)
minor yum.conf and yum.spec changes

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Made some minor changes.  See attached patch.

http://angus.ind.wpi.edu/~cra/fedora/legacy/yum/

5fe72044bd3823ee7c32cc535ec5bcf6035d8660  yum-2.0.5-0.9.2.legacy-changes.patch
42662e40a04cb5ea0eb9dc16856ef8e27ed1386f  yum-2.0.5-0.9.2.legacy.noarch.rpm
11239bfe384fec8c510e6e0cfcc1ec74169821c9  yum-2.0.5-0.9.2.legacy.src.rpm

%changelog
* Sun Oct  3 2004 Charles R. Anderson <cra@wpi.edu> 2.0.5-0.9.2.legacy
- - add explicit Epoch: 0
- - clean up pre/post scriptlets
- - only run chkconfig --add on initial installs, not upgrades
- - remove $basearch from [updates-testing] name, since it isn't in the others

Tested successfully on RH9 system.
Please QA.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.7 (GNU/Linux)

iD8DBQFBX4cFw2eg+Um7WIYRAncoAJ9e7VvwKewX9x9fFBoGrCKLRxD08gCgg/eZ
I0k4FM3DK3nyVXHRnfCp5l8=
=YnNH
-----END PGP SIGNATURE-----




------- Additional Comments From marcdeslauriers@videotron.ca 2004-10-21 14:57:50 ----

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Did QA on the following package:

11239bfe384fec8c510e6e0cfcc1ec74169821c9  yum-2.0.5-0.9.2.legacy.src.rpm

- - Spec file changes are OK
- - conf file changes OK
- - Sources match original
- - Builds and runs

+PUBLISH

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQFBeFs0LMAs/0C4zNoRAoHQAKCFbpW3RfhDtbVWvASv+KjIFY0TRQCbBrH5
W5Jwmr6HciGXwZkqoZHt7sc=
=nzkU
-----END PGP SIGNATURE-----




------- Additional Comments From sheltren@cs.ucsb.edu 2004-10-22 04:19:51 ----

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

QA for the package:
11239bfe384fec8c510e6e0cfcc1ec74169821c9  yum-2.0.5-0.9.2.legacy.src.rpm

Spec file looks good
yum.conf file is OK
Source tarball matches original
Builds cleanly
Installs and runs OK

PUBLISH++
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (Darwin)

iD8DBQFBeRbHKe7MLJjUbNMRAv4LAJ9txfdAtpSvVf6qlllgA77j7tAXmwCfRbev
6xYoPxHuiycsIif1REasT6U=
=e+hR
-----END PGP SIGNATURE-----



------- Additional Comments From dom@earth.li 2004-10-23 01:05:43 ----

Can someone summarise why we need this package? People seem to be using yum for
rh9 quite successfully already, I gather.



------- Additional Comments From marcdeslauriers@videotron.ca 2004-10-23 01:11:59 ----

Because they are getting yum from fedora.us and have to manually modify the
yum.conf file and manually download the fedoralegacy key.

Compare this:
http://www.fedoralegacy.org/docs/yum-rh7x.php

to this:
http://www.fedoralegacy.org/docs/yum-rh9.php



------- Additional Comments From marcdeslauriers@videotron.ca 2005-02-28 15:39:20 ----

Packages were released to the legacy-utils directory



------- Additional Comments From skvidal@phy.duke.edu 2005-02-28 15:44:37 ----

2.0.5??
why 2.0.5?



------- Bug moved to this database by dkl@redhat.com 2005-03-30 18:25 -------

This bug previously known as bug 1604 at https://bugzilla.fedora.us/
https://bugzilla.fedora.us/show_bug.cgi?id=1604
Originally filed under the Fedora Legacy product and Package request component.

Attachments:
minor yum.conf and yum.spec changes
https://bugzilla.fedora.us/attachment.cgi?action=view&id=870

Unknown priority P2. Setting to default priority "normal".
Unknown platform PC. Setting to default platform "All".
Setting qa contact to the default for this product.
   This bug either had no qa contact or an invalid one.


Note You need to log in before you can comment on or make changes to this bug.