This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 15273 - RFE: Translateable passwd
RFE: Translateable passwd
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: passwd (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
: FutureFeature
Depends On: 143873
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-03 13:21 EDT by Christian Rose
Modified: 2013-07-02 18:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-14 13:30:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Christian Rose 2000-08-03 13:21:46 EDT
The userpasswd program in usermode seems to be only be wrapping the output
of the
passwd program in a GTK window. This means that userpasswd isn't really
translateable, since passwd isn't translateable. :(

In the future, I'd thus really like to see a translateable "passwd" with
gettext support.
Comment 1 Nalin Dahyabhai 2000-09-12 16:04:13 EDT
A translatable passwd command also requires translatable modules in PAM, which
is going to affect several packages....
Comment 2 Christian Rose 2000-12-17 22:05:01 EST
In that case I guess my translation request will cover those modules too... :-)
Comment 3 Jindrich Novy 2004-12-14 13:30:07 EST
Christian, could you please file a bug against pam regarding the
issue? Passwd actually calls pam and libuser for user authentication,
so the messages need to be translated there.
Comment 4 Christian Rose 2004-12-30 10:33:04 EST
Ok, added bug 143873.

Note You need to log in before you can comment on or make changes to this bug.