Bug 152864 - yum update
yum update
Status: CLOSED CURRENTRELEASE
Product: Fedora Legacy
Classification: Retired
Component: General (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Fedora Legacy Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-07 01:35 EST by Anatoly Pugachev
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Lawrence 2005-03-30 18:30:09 EST
Hello.

Using redhat-7.3. Installed yum from
http://download.fedoralegacy.org/redhat/7.3/legacy-utils/i386/yum-1.0.3-6.0.7.x.legacy.noarch.rpm

trying to get update for zlib, got following error:
...
[root@Test4 cache]# yum update zlib zlib-devel
Gathering package information from servers
Getting headers from: Red Hat Linux 7.3 base
Getting headers from: Fedora Legacy utilities for Red Hat Linux 7.3
Getting headers from: Red Hat Linux 7.3 updates
Finding updated packages
Downloading needed headers
getting /var/cache/yum/updates/headers/kdesdk-kbabel-0-3.0.5a-0.73.0.i386.hdr
Damaged Header /var/cache/yum/updates/headers/kdesdk-kbabel-0-3.0.5a-0.73.0.i386.hdr
getting /var/cache/yum/updates/headers/kdesdk-kbabel-0-3.0.5a-0.73.0.i386.hdr
Damaged Header /var/cache/yum/updates/headers/kdesdk-kbabel-0-3.0.5a-0.73.0.i386.hdr
getting /var/cache/yum/updates/headers/kdesdk-kbabel-0-3.0.5a-0.73.0.i386.hdr
Damaged Header /var/cache/yum/updates/headers/kdesdk-kbabel-0-3.0.5a-0.73.0.i386.hdr
getting /var/cache/yum/base/headers/gnome-games-devel-1-1.4.0.1-5.i386.hdr
Damaged Header /var/cache/yum/base/headers/gnome-games-devel-1-1.4.0.1-5.i386.hdr
getting /var/cache/yum/base/headers/gnome-games-devel-1-1.4.0.1-5.i386.hdr
Damaged Header /var/cache/yum/base/headers/gnome-games-devel-1-1.4.0.1-5.i386.hdr
getting /var/cache/yum/base/headers/gnome-games-devel-1-1.4.0.1-5.i386.hdr
Damaged Header /var/cache/yum/base/headers/gnome-games-devel-1-1.4.0.1-5.i386.hdr
getting /var/cache/yum/updates/headers/kdegames-devel-6-3.0.5a-0.73.0.i386.hdr
Damaged Header
/var/cache/yum/updates/headers/kdegames-devel-6-3.0.5a-0.73.0.i386.hdr
getting /var/cache/yum/updates/headers/kdegames-devel-6-3.0.5a-0.73.0.i386.hdr
Damaged Header
/var/cache/yum/updates/headers/kdegames-devel-6-3.0.5a-0.73.0.i386.hdr
getting /var/cache/yum/updates/headers/kdegames-devel-6-3.0.5a-0.73.0.i386.hdr
Damaged Header
/var/cache/yum/updates/headers/kdegames-devel-6-3.0.5a-0.73.0.i386.hdr
Resolving dependencies
Dependencies resolved
I will do the following:
[update: zlib-devel.i386]
[update: zlib.i386]
Is this ok [y/N]: y
IOError - # 2 - No such file or directory
[root@Test4 cache]#

part of 'strace yum update zlib' :
...
open("/var/cache/yum/base/headers/gsl-0-1.1.1-1.i386.hdr", O_RDONLY) = 6
fstat64(6, {st_mode=S_IFREG|0644, st_size=2700, ...}) = 0
fstat64(6, {st_mode=S_IFREG|0644, st_size=2700, ...}) = 0
fstat64(6, {st_mode=S_IFREG|0644, st_size=2700, ...}) = 0
open("/var/cache/yum/updates/headers/kdesdk-kbabel-0-3.0.5a-0.73.0.i386.hdr",
O_RDONLY) = -1 ENOENT (No such fil
e or directory)
open("/var/cache/yum/updates/headers/kdesdk-kbabel-0-3.0.5a-0.73.0.i386.hdr",
O_RDONLY) = -1 ENOENT (No such fil
e or directory)
unlink("/var/run/yum.pid")              = 0
...

so it looks like bad headers hit repository. Can someone make another check or
re-create this headers?



------- Additional Comments From dom@earth.li 2005-02-22 16:07:07 ----

Is this fixed?



------- Additional Comments From dom@earth.li 2005-03-07 07:10:57 ----

I'm assuming this is fixed. Please reopen the bug if not, thanks.



------- Bug moved to this database by dkl@redhat.com 2005-03-30 18:30 -------

This bug previously known as bug 2330 at https://bugzilla.fedora.us/
https://bugzilla.fedora.us/show_bug.cgi?id=2330
Originally filed under the Fedora Legacy product and General component.

Unknown priority P2. Setting to default priority "normal".
Unknown platform PC. Setting to default platform "All".
Unknown severity blocker. Setting to default severity "normal".
Setting qa contact to the default for this product.
   This bug either had no qa contact or an invalid one.


Note You need to log in before you can comment on or make changes to this bug.