Bug 152867 - rpm-4.2-0.69 as shipped with RHL9 is buggy; update to 4.2-1
rpm-4.2-0.69 as shipped with RHL9 is buggy; update to 4.2-1
Status: CLOSED WONTFIX
Product: Fedora Legacy
Classification: Retired
Component: rpm (Show other bugs)
rhl9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dominic Hargreaves
ftp://ftp.rpm.org/pub/rpm/test-4.2/
LEGACY, rh90, needsbuild
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-07 21:08 EST by Matthew Miller
Modified: 2007-04-18 13:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-04 08:06:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Lawrence 2005-03-30 18:30:15 EST
Red Hat Linux 9 was never officially updated to rpm 4.2-1 -- it's still got
4.2-0.69. The newer version, from <ftp://ftp.rpm.org/pub/rpm/test-4.2/>, solves
the incredibly common problem of RPM getting itself into a state where it just
hangs until you manually clean up its __db.nnn files.

I think it would be quite reasonable to put out this update for Fedora
Legacy. We've been using this updated version in BU Linux 3.0 (which is
RHL9-based) for over a year now, with great results.

One upstream bug report relating to this is: 

  https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=88164

It's marked as "closed:errata" and refers to the above ftp.rpm.org packages.
There never was a more official errata. We should include the fix in Fedora
Legacy, for RHL9 at least.



------- Additional Comments From pekkas@netcore.fi 2004-12-21 08:37:55 ----

I'd have no problem with this update; we certainly have run rpm-4.2-1 on our
RHL9 systems for ages.



------- Bug moved to this database by dkl@redhat.com 2005-03-30 18:30 -------

This bug previously known as bug 2333 at https://bugzilla.fedora.us/
https://bugzilla.fedora.us/show_bug.cgi?id=2333
Originally filed under the Fedora Legacy product and Package request component.

Unknown priority P3. Setting to default priority "normal".
Setting qa contact to the default for this product.
   This bug either had no qa contact or an invalid one.

Comment 1 Jeff Johnson 2005-03-31 07:18:43 EST
A bit late for an errata for a non-supported product.

And I'd suggest at least rpm-4.2.2-0.8 (rpm-4.4.1 is both doable and
recommended), as there are other issues that are long long since fixed in rpm.
Comment 2 Matthew Miller 2005-03-31 08:37:34 EST
Reopening. This *is* a supported product -- note, Fedora Legacy.

Updating to a much newer version isn't necessarily a good idea, but updating to
this particular release fits within FL's mission, since having the old version
can prevent security patches from being properly applied.
Comment 3 Jeff Johnson 2005-04-11 08:07:02 EDT
Then rebuild rpm-4.2-1 from ftp.rpm.org. The fix has been there for ages.
Comment 4 Matthew Miller 2005-04-11 09:46:38 EDT
Um, yes, that is exactly the suggestion.
Comment 5 Jeff Johnson 2005-11-04 08:06:32 EST
I doubt that Red Hat is ever gonna properly release an errata for rpm-4.2-0.69.

Meanwhile, if all you want is a "working" and "released" version of rpm for Fedora Legacy,
I will be happy to build that and release on wraptastic.org. In fact, you might want
to look at the rpm-4.4.3-0.34 packages in the yum repository at
    http://wraptastic.org/pub/i386-CentOS3-linux/RPMS

Mail to <rpm-devel@lists.dulug.duke.edu> if all you want is a working/released rpm.
Comment 6 Matthew Miller 2006-07-25 14:59:54 EDT
Jeff, did you close this again? Please don't -- I still think we should release
this update before RHL9 support goes away completely. The issue comes up
periodically on the Fedora Legacy list, so clearly it's still causing issues.

Note You need to log in before you can comment on or make changes to this bug.