Bug 152914 - Possible string bug introduced in php updates
Possible string bug introduced in php updates
Status: CLOSED WORKSFORME
Product: Fedora Legacy
Classification: Retired
Component: General (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Fedora Legacy Bugs
LEGACY
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-07 12:55 EST by Marc Deslauriers
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Lawrence 2005-03-30 18:31:52 EST
I received this by e-mail:

Hello Marc,

Not sure who to contact but found your email address in the package info 
for these recently updated fedora legacy packages.

03/07/05 04:56:46 Updated: php-mbstring 4.3.10-1.1.legacy.i386
03/07/05 04:56:46 Updated: php 4.3.10-1.1.legacy.i386
03/07/05 04:56:46 Updated: php-mysql 4.3.10-1.1.legacy.i386

I suspect there might be a new bug in this software, but sorry I don't
think I can give you a specific repeatable example...  I suspect there
might be a problem in php or php-mbstring, since upgrading to these
packages, a few pieces of code that look like this:

foreach($queries as $qry)....

results in $qry turned into an array, when it was a string.  I guess you 
could repeat the problem when installing WordPress (wordpress.org).  This 
problem also showed up in another script but after using "explode" on an 
array of strings.  It looks like the structure of the string/array is:

Array
(
    [0] => this is my string
    [1] => 0
)

I think this a real bug in php or php-mbstring, since it only started 
after I updated these packages. If you know anything about this problem, 
please let me know if I can provide you with anything further to help.

Thanks,
Ethan



------- Additional Comments From marcdeslauriers@videotron.ca 2005-03-07 14:22:39 ----

This may be caused by using Zend Optimizer. I sent the reporter a private mail.



------- Additional Comments From marcdeslauriers@videotron.ca 2005-03-07 16:41:17 ----

Thanks Marc, this was the exact problem!  I don't remember installing Zend
optimizer, but sure enough, an old version was installed (v2.5.2)  After
upgrading to the latest Zend optimizer, everything works great.

Thanks again,
Ethan



------- Bug moved to this database by dkl@redhat.com 2005-03-30 18:31 -------

This bug previously known as bug 2445 at https://bugzilla.fedora.us/
https://bugzilla.fedora.us/show_bug.cgi?id=2445
Originally filed under the Fedora Legacy product and General component.

Unknown priority P2. Setting to default priority "normal".
Unknown platform PC. Setting to default platform "All".
Setting qa contact to the default for this product.
   This bug either had no qa contact or an invalid one.


Note You need to log in before you can comment on or make changes to this bug.