Bug 152943 - Using lvm on 64-bit version of linux causes driver upgrades on 3ware 9500 series to render RAID array unaccessible
Using lvm on 64-bit version of linux causes driver upgrades on 3ware 9500 ser...
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Alasdair Kergon
Depends On:
  Show dependency treegraph
Reported: 2005-03-30 23:11 EST by Bob Kuo
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-08-08 11:12:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bob Kuo 2005-03-30 23:11:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)

Description of problem:
I currently have the 64-bit version of Fedora Core 3 installed, and I'm using a 3ware 9500S-12 RAID controller with LVM. According to the 3ware website (search for "LVM" or article 13297 in the knowledgebase), if you try to update their driver with this combination (64-bit Linux with LVM), the RAID array will become unusable.

I haven't actually tried to update my 3ware driver because I don't want to lose access to my RAID array. I have contacted 3ware customer support and they say that it is a Linux bug.

Version-Release number of selected component (if applicable):

How reproducible:
Didn't try

Steps to Reproduce:
1.Have a 64-bit version of Linux, a 3ware controller card, and LVM
2.Try to upgrade the driver

Actual Results:  I haven't tried it myself.

Expected Results:  The driver should update and the RAID should still be accessible.

Additional info:
Comment 1 Alasdair Kergon 2005-03-31 08:43:36 EST
Sorry, but this is too vague.

What exactly fails?
What error messages?

Which driver?   3ware 9xxx SATA-RAID support (3w-9xxx)?

Are mkinitrd options being used to include the module?
Comment 2 Bob Kuo 2005-03-31 14:38:26 EST
I apologize for the vagueness. It's hard for me to provide details since I 
haven't tried to replicate the bug on my system, and I'm only going off of a 
report from the 3ware website. I was hoping 3ware had submitted a bug report 
when I first checked Bugzilla.

In any case, I will contact 3ware technical support again and refer them to 
this bug to see if they can provide more details.
Comment 3 Alasdair Kergon 2005-08-08 11:12:11 EDT
Please reopen when you receive clarification.

Note You need to log in before you can comment on or make changes to this bug.