Bug 152948 - Fish panel references non-existent file
Fish panel references non-existent file
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-31 02:35 EST by Sean Earp
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.10.1-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-25 06:58:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sean Earp 2005-03-31 02:35:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050328 Firefox/1.0.2 Fedora/1.0.2-3

Description of problem:
If you add "Fish" to the Gnome panel, you are supposed to be able to click on it and get a fortune.

It gets the fortune (right click on the fish and choose "properties") from:

/usr/X11R6/lib/xscreensaver/fortune

This is a non-existent location in FC4Test1, and for that matter I am not able to find the "fortune" screensaver anywhere in the installation:

[smearp@localhost X11R6]$ locate fortune
/usr/share/terminfo/f/fortune
/usr/share/gnome/help/aisleriot/C/fortunes.xml
/usr/share/gnome/help/aisleriot/fr/fortunes.xml
/usr/share/sol-games/fortunes.scm
/usr/share/emacs/21.3/lisp/play/fortune.elc


Version-Release number of selected component (if applicable):
gnome-panel-2.10.0-2

How reproducible:
Always

Steps to Reproduce:
1.Add "fish" to gnome panel
2.Click on the fish
3.Receive error message "unable to locate the command to execute"
  

Actual Results:  Error message

Expected Results:  A fortune from Wanda the Fish

Additional info:
Comment 1 Mark McLoughlin 2005-04-07 07:57:36 EDT
Ray: was fortune removed from xscreensaver ?
Comment 2 Ray Strode [halfline] 2005-04-07 17:14:49 EDT
The fake fortune standin thing was removed for 4.21. 
It hasn't been installed in /usr/X11R6/lib/xscreensaver/fortune for quite some
time though.  I changed xscreensaver to use a more standard directory structure
a few months ago (so the mock fortune thing was installed in
/usr/libexec/xscreensaver/fortune).  If gnome-panel depends on it, then it
should probably just include itself.
Comment 3 Sean Earp 2005-04-09 14:36:04 EDT
So is this something I should report up to Gnome's bugzilla, or just a
configuration change on Mark's end that needs to happen?
Comment 4 Sean Earp 2005-04-09 14:38:46 EDT
FWIW, fortune is not included amongst the screensavers in /usr/libexec/xscreensaver:

[smearp@localhost ~]$ cd /usr/libexec/xscreensaver
[smearp@localhost xscreensaver]$ ls
antinspect    circuit         gflux         lament      queens
antspotlight  cubenetic       glblur        lavalite    rubik
atlantis      cubestorm       gleidescope   menger      sballs
atunnel       dangerball      glforestfire  mirrorblob  sierpinski3d
blinkbox      endgame         glknots       moebius     spheremonics
blocktube     engine          glmatrix      molecule    sproingies
boing         flipflop        glplanet      noof        stairs
bouncingcow   flipscreen3d    glslideshow   pinion      starwars
boxed         fliptext        glsnake       polyhedra   stonerview
bubble3d      flurry          hypertorus    polytopes   superquadrics
cage          flyingtoasters  jigglypuff    providence
carousel      gears           klein         pulsar
Comment 5 Ray Strode [halfline] 2005-04-11 10:31:05 EDT
Hi Sean,

This is a Fedora specific issue.  

Fortune is a program that prints random quotes.  The problem is that we don't
ship Fortune in Fedora (we used to).  XScreenSaver used to use the fortune
program to display text in its screensavers.  When fortune was removed
XScreenSaver was changed over to use a fortune "stand-in" program which just
printed the version of Red Hat, the version of the kernel, and the box's
uptime/load average.  Apparently sometime after that gnome-panel was changed to
depend on xscreensaver's fortune stand-in program to display the quote from
Wanda, the fish applet.  A few months ago, I moved where the fortune stand in
program was installed in XScreenSaver.  A few weeks ago, I removed it entirely.  

The easiest fix is for Mark to include a fortune standin program in our
gnome-panel package.  This program doesn't really need to be installed for
upstream because people using upstream versions of gnome can install fortune
themselves.
Comment 6 Jef Spaleta 2005-04-23 15:16:02 EDT
(In reply to comment #2)
> If gnome-panel depends on it, then it
> should probably just include itself.

Or the gnome-panel fish could just default to something like
cat /etc/fedora-release  if the fish is the only thing using the script outside
of the xscreensaver zoo.  Since fortune is part of Extras using the stand-in
script does make the panel fish potentially more functional without additional
configuration for people who want to install the fortune from Extras. As soon as
fortune is on the system the the panel fish starts grabbing qoutes again.

If there is something else in Core (and Extras) that wanted to interact with
fortune, perhaps it would be better to include that standin script in
fedora-release or something instead of duplicating the script in multiple
packages.  I can't think of anything else that might be using fortune so thats a
rather hypothetical if situation.

-jef
Comment 7 O.R.Senthil Kumaran 2005-04-24 11:26:40 EDT
Hi All,
A discussion took place in the list for including fortune program.
My suggestios was:
Include fortune and fedora-tips ( linux-tips,kernel-tips) dat file.
That should resolve the issue of wanda fish as well as ship the much admired
fortune package.

Fedoraproject.org extras has two fortune-mod packages:
Fortune-mod-1.0.25
Fortune-mod-1.99.1-2

I have written to the second packager's maintainer to consider the
option of providing fortune with tips only as dat file and a separate rpm for
other dat files which can be downloaded.
Comment 8 Mark McLoughlin 2005-04-25 06:58:42 EDT
I've just gone and changed the default command to "ddate"

* Mon Apr 25 2005 Mark McLoughlin <markmc@redhat.com> 2.10.1-3
- Add patch to make Wanda not use non-existent fortune
  command (rh #152948)

Note You need to log in before you can comment on or make changes to this bug.