This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 153007 - krb5-devel doesn't include header files included with kerberos source
krb5-devel doesn't include header files included with kerberos source
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: krb5 (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-31 16:19 EST by David Backeberg
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-11 10:54:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Backeberg 2005-03-31 16:19:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050324 Fedora/1.7.6-1.3.2

Description of problem:
krb5-devel rpm includes the following headers:
/usr/include/gssapi
/usr/include/gssapi/gssapi.h
/usr/include/gssapi/gssapi_generic.h
/usr/include/gssapi/gssapi_krb5.h
/usr/include/kerberosIV
/usr/include/kerberosIV/des.h
/usr/include/kerberosIV/kadm_err.h
/usr/include/kerberosIV/krb.h
/usr/include/kerberosIV/krb_err.h
/usr/include/kerberosIV/mit-copyright.h
/usr/include/krb5.h
/usr/include/profile.h

That's a nice start...

I would like to also have
/usr/include/kadm5/admin.h
/usr/include/gssrpc/rpc.g
/usr/include/k5-int.h
/usr/include/com_err.h
/usr/include/kadm5/kadm_err.h
/usr/include/kadm5/adb_err.h
/usr/include/kadm5/chpass_util_strings.h

Essentially, I want all the header files that are in /src/include in the actual MIT kerberos source tarball to end up in /usr/include after installing the krb5-devel package. I've also installed a krb5-include rpm. If they should go in there instead, I'm fine with that.

Version-Release number of selected component (if applicable):
krb5-1.3.4-12.src.rpm, creates rpms including krb5-devel

How reproducible:
Always

Steps to Reproduce:
1.install every kerberos rpm you know about:
rpm -qa | grep krb
krb5-libs-1.3.4-12
krbafs-1.2.2-6
krb5-server-1.3.4-12
krb5-workstation-1.3.4-12
krb5-auth-dialog-0.2-1
krbafs-devel-1.2.2-6
pam_krb5-2.1.2-1
krb5-devel-1.3.4-12
2. try to build pam_krb5_migrate, from http://freshmeat.net/projects/pam_krb5_migrate
3. Discover that a package that implies development files are included is an incomplete set of the development libraries.
  

Actual Results:  Trying to build src package bombs out, looking for kerberos header files that exist in the source tarball from MIT, but don't exist in the rpms from Redhat.  Perhaps there is a specially named rpm that I don't know about.

Expected Results:  Headers should be on system, code should build.

Additional info:

Kerberos tarball can be downloaded from http://web.mit.edu/kerberos/www/
Comment 2 Nalin Dahyabhai 2006-08-11 10:54:45 EDT
The headers in question are not installed because they're library-internal
(k5-int.h in particular).  As a result, you'd have no guarantees that the
interfaces would remain stable.  We erroneously some of the kadm5 headers in the
past, and that led to real problems later on.  I have to close this as won't-fix.

Note You need to log in before you can comment on or make changes to this bug.