This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 153070 - Programs using alarm/pause never terminate.
Programs using alarm/pause never terminate.
Status: CLOSED DUPLICATE of bug 143867
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: clumanager (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Lon Hohberger
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-01 06:23 EST by Harry Venema
Modified: 2009-04-16 16:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-01 10:23:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Harry Venema 2005-04-01 06:23:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
The following simple C program never terminates when called from a user script.

#include <unistd.h>
int main()
{
        alarm(5);
        pause();
        return 0;
}


Version-Release number of selected component (if applicable):
clumanager-1.2.22-2

How reproducible:
Always

Steps to Reproduce:
1. Start cluster service with user script using program that uses alarm / pause combination.

  

Actual Results:  called program never terminates

Expected Results:  Program should terminate after # of seconds

Additional info:
Comment 1 Lon Hohberger 2005-04-01 10:23:46 EST
This will be fixed in the next update.  Thanks for the report.

*** This bug has been marked as a duplicate of 143867 ***

Note You need to log in before you can comment on or make changes to this bug.