This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 153083 - No sound with via82xx, disabled irq
No sound with via82xx, disabled irq
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-01 09:28 EST by Göran Uddeborg
Modified: 2015-01-04 17:18 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-07 17:59:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Excerpt from messages, with the Disabled IRQ message (1.58 KB, text/plain)
2005-04-01 09:29 EST, Göran Uddeborg
no flags Details
Output from "lspci -v" (4.58 KB, text/plain)
2005-04-01 09:30 EST, Göran Uddeborg
no flags Details

  None (edit)
Description Göran Uddeborg 2005-04-01 09:28:16 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Fedora/1.7.6-1.3.2

Description of problem:
When installing FC4t1 on a brand new computer, I could not hear any sound.  Upgrading to the latest development kernel did not help.

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.1219_FC4

How reproducible:
Always

Steps to Reproduce:
1.Install FC4t1
2.Run system-configure-soundcard
3.Play the test sound

Actual Results:  Nothing

Expected Results:  A sound from the speakers.

Additional info:

When booting, I got the error message "Disabling IRQ #10".  This prompted me to try with "acpi=off" on the command line.  And that did help, I now do get sound.  So I have a workaround, but I guess I'm not supposed to have to do that.
Comment 1 Göran Uddeborg 2005-04-01 09:29:50 EST
Created attachment 112582 [details]
Excerpt from messages, with the Disabled IRQ message
Comment 2 Göran Uddeborg 2005-04-01 09:30:55 EST
Created attachment 112583 [details]
Output from "lspci -v"
Comment 3 Dave Jones 2005-06-27 19:16:27 EDT
Mass update of -test bugs to update version to fc4.
(Please retest on final release, and report results if you have not already done
so).

Thanks.
Comment 4 Göran Uddeborg 2005-07-02 17:21:05 EDT
I can not do a clean reinstall of the machine.  But I upgraded to the recently
released kernel-2.6.12-1.1387_FC4.  With this kernel, sound works even without
any acpi flags on the kernel command line.

Seems to be solved.

Note You need to log in before you can comment on or make changes to this bug.