Bug 153107 - In rpm update dhclient-3.0.1-10_EL3 on line 52 of the /sbin/dhclient-script script it calls a function change_resolv_conf and that function does not seem to exist in the script of in any of the sourced files When you do a ifup eth0 or eth1 it fails ...
In rpm update dhclient-3.0.1-10_EL3 on line 52 of the /sbin/dhclient-script s...
Status: CLOSED DUPLICATE of bug 146817
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: dhcp (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-01 11:37 EST by Jon Sabo
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-02 15:07:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Sabo 2005-04-01 11:37:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050322 Firefox/1.0.2 Red Hat/1.0.2-1.4.1

Description of problem:
In rpm update dhclient-3.0.1-10_EL3 on line 52 of the /sbin/dhclient-script script it calls a function change_resolv_conf and that function does not seem to exist in the script of in any of the sourced files  

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. /sbin/ifup eth1 
2.
3.
  

Actual Results:  it fails to write /etc/resolv.conf and says it cant find function in line 52 of /sbin/dhclient-script

Expected Results:  work

Additional info:
Comment 1 Jason Vas Dias 2005-04-02 15:07:21 EST
It looks like you may not have the latest "initscripts" package .
dhcp-3.0.1-10_EL3 was designed to work with initscripts-7.31.17.EL+ ,
whose '/etc/sysconfig/network-scripts/network-functions' script
implements the 'change_resolv_conf' function required by 
/sbin/dhclient-script . This function is also implemented in the 
latest initscripts-7.31.21.EL package for RHEL-3, and in RHEL-3-U4's
initscripts-7.32.18.EL package .  
Use 'up2date' to update to latest RHEL-3-U4 build and obtain 
initscripts-7.32.18.EL to fix this problem.
If you had modified the default "network-functions" script from the
previous initscripts release, upgrading to the latest initscripts
release may not update the network-functions script, but would
create a network-functions.rpmnew file.
If you have the file /etc/sysconfig/network-scripts/network-functions.rpmnew
file, move it to /etc/sysconfig/network-scripts/network-functions and the
problem should disappear. If it does not, please let me know.

*** This bug has been marked as a duplicate of 146817 ***
Comment 2 Jon Sabo 2008-08-02 16:16:37 EDT
The original summary for this bug was longer than 255 characters, and so it was truncated when Bugzilla was upgraded. The original summary was:

In rpm update dhclient-3.0.1-10_EL3 on line 52 of the /sbin/dhclient-script script it calls a function change_resolv_conf and that function does not seem to exist in the script of in any of the sourced files    When you do a ifup eth0 or eth1 it fails to write /etc/resolv.conf and comes up with an error indicating that it cant find the function already mentioned.

Note You need to log in before you can comment on or make changes to this bug.