This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 153201 - Laptop touchpad performance problems with kernel 2.6.11
Laptop touchpad performance problems with kernel 2.6.11
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 154716 154790 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-02 14:22 EST by Aaron Gaudio
Modified: 2015-01-04 17:18 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-11 18:28:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Aaron Gaudio 2005-04-02 14:22:49 EST
Description of problem:
I have a Sony VAIO R505E series. Using kernel 2.6.10, my touchpad apparently
gets detected as "Generic PS/2 Mouse" and this is fine. The touchpad performs as
expected, and hardware tapping is on, which is what I like (I know that others
have different opinions on this).

After upgrading to kernel 2.6.11, however, my touchpad is detected as an ALPS
Glidepoint, HW tapping is turned off by default (and I don't know how to turn it
back on for both X AND gpm) and most importantly, the mouse cursor movement is
VERY slow and choppy, making it virtually impossible to use. As this is my
primary pointer device when using my laptop, I've had to revert to using kernel
2.6.10 until this is resolved.

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.7_FC3.protho (I rebuilt to enable Software Suspend, I did this
with kernel-2.6.10-1.770_FC3 as well, so I'm sure this isn't the cause of the
problem).

How reproducible:
Always

Steps to Reproduce:
1. (Not sure if this affects all ALPS Glidepoint devices.) Upgrade to
kernel-2.6.11-1.7_FC3 while using an ALPS Glidepoint device.
  
Actual results:
Mouse cursor is very choppy, hardware tapping (double-tap the touchpad for a
simulated mouse button 1 press) is disabled by default.

Expected results:
Mouse cursor movement is a smooth as in kernel 2.6.10. Hardware tapping is
enabled by default to preserve legacy behavior, presumably there is an option to
sysctl or something to disable it (that should be documented).

Additional info:
I did a google search on this problem and found this thread which seems to
describe the same problem:
http://seclists.org/lists/linux-kernel/2005/Mar/index.html#2072

Note that the Fedora kernel apparently doesn't compile the psmouse driver as a
module (why not?) so I believe the workaround suggested in the first email (use
the proto=exps option) is not available to me unless I reconfigure and rebuild
the kernel. Later in the thread, it seems like the chopiness problem may be
fixed in a 2.6.12-rc version...
Comment 1 Arnaud Abélard 2005-04-11 08:25:58 EDT
On a DELL D400 laptop, the touchpad still gets detected but the tapping is now
way too sensitive... not sure it's the same problem, but i can only reproduce
this with FC3's 2.6.11 kernels (-7 and -14) from updates-testing (works fine
with 2.6.10 and haven't tried vanilla kernels)
Comment 2 Fulko Hew 2005-04-11 21:58:28 EDT
I just upgraded to kernel 2.6.11-1.14_FC3 from 2.6.10-1.770_FC3 and my touchpad
now exhibits the same symptoms after the upgrade: jerky motion and no more
single, double ot triple 'tap' operation.

The 2.6.11 'broken' kernel now reports my mousepad as:

Apr 11 20:27:33 localhost kernel: ALPS Touchpad (Glidepoint) detected
Apr 11 20:27:33 localhost kernel:   Disabling hardware tapping
Apr 11 20:27:33 localhost kernel: input: AlpsPS/2 ALPS TouchPad on isa0060/serio4

The older 'working' kernel (2.6.10) reports the mousepad as:

Apr 11 21:11:10 localhost kernel: input: PS/2 Generic Mouse on isa0060/serio4

Comment 3 Adam Bowns 2005-04-13 17:57:20 EDT
I have also encountered the same problems you guys are having, after upgrading
to kernel 2.6.11-1.14 movement on the touchpad of my Vaio FX-201 laptop became
very jumpy and nearly unusable. In addition tapping the touchpad no longer acts
as a mouse click, it is simply ignored.

This is not a problem with the laptop because booting back into
kernel-2.6.10-1.770 makes the touchpad work perfectly.

I don't know how this kernel passed QA guys, its totally unusable on 2 / 2 of my
systems.
Comment 4 Paul Johnson 2005-04-14 01:05:30 EDT
I have the same trouble on a DELL 8600. The touchpad is jumpy as heck after the
kernel upgrade to 2.6.11.  Like the previous report, with kernel upgrade 2.6.10,
the startup says

Apr 13 00:04:00 pols111 kernel: mice: PS/2 mouse device common for all mice
Apr 13 00:04:00 pols111 kernel: input: AT Translated Set 2 keyboard on
isa0060/serio0
Apr 13 00:04:00 pols111 kernel: input: PS/2 Generic Mouse on isa0060/serio1


With 2.6.11, it has a more-detailed and correct looking message:

Apr 12 23:26:48 pols111 kernel: mice: PS/2 mouse device common for all mice
Apr 12 23:26:48 pols111 kernel: input: AT Translated Set 2 keyboard on
isa0060/serio0
Apr 12 23:26:48 pols111 kernel: ALPS Touchpad (Dualpoint) detected

I have no way of knowing if this laptop actually has ALPS Dualpoint. How could I?

I've been scanning the internet and I have seen several suggested patches for
the kernel, but I'll prefer to wait until the experts say it is save to step up
again.
Comment 5 Peter K 2005-04-14 05:26:38 EDT
*** Bug 154716 has been marked as a duplicate of this bug. ***
Comment 6 Peter K 2005-04-14 05:31:38 EDT
Summary from bug 154716:

no form of tapping possible since the alps support was merged into 2.6.11 (Sony
vaio R505TSK).

with X using default/legacy ps2 mode I see the same jerky movements as the
original poster. with X using the synaptics driver movements are ok but still no
tapping.

I backed down to 2.6.10-770 since this is my primary (only) pointing device.
 
Comment 7 Dave Jones 2005-04-14 15:10:35 EDT
*** Bug 154790 has been marked as a duplicate of this bug. ***
Comment 8 Chris 2005-04-14 17:19:05 EDT
I'm running a Toshiba Satellite A10 and the touchpad turned into an Apple style
one one me (no touch tap) after upgrading kernels:

[nesscg@heidrun ~]$ uname -a
Linux heidrun.localdomain 2.6.11-1.14_FC3 #1 Thu Apr 7 19:23:49 EDT 2005 i686
i686 i386 GNU/Linux

Interesting DMESG Output:
=========================
drivers/usb/input/hid-core.c: v2.0:USB HID core driver
mice: PS/2 mouse device common for all mice
input: AT Translated Set 2 keyboard on isa0060/serio0
ALPS Touchpad (Glidepoint) detected
  Disabling hardware tapping
input: AlpsPS/2 ALPS TouchPad on isa0060/serio1
md: md driver 0.90.1 MAX_MD_DEVS=256, MD_SB_DISKS=27

Anybody know how to enable hardware tapping?
Chris
Comment 9 Avi Jacobson 2005-04-17 00:58:21 EDT
Same issue exactly with Acer TravelMate 290. 2.6.10-1.770_FC3 works fine; 
2.6.11-1.14_FC3  produces the behavior described.

Thanks,
Avi
Comment 10 Abdul Basit 2005-04-18 14:04:16 EDT
On my Sony VAIO GRT-170, it happens the same, it detects it as
input: AT Translated Set 2 keyboard on isa0060/serio0
ALPS Touchpad (Glidepoint) detected
  Disabling hardware tapping
input: AlpsPS/2 ALPS TouchPad on isa0060/serio1

With 2.6.10 it works fine, with 2.6.11, the mouse / touchpad is screwed.

Basit.
Comment 11 Paul Morgan 2005-04-24 23:26:48 EDT
Same problem here. Have improved situation a little by using workaround
suggested on fedora users list (see below for /etc/X11/xorg.conf section),
but double-tapping still doesn't work in gterm or address bar of firefox:

Section "InputDevice"
  Driver        "synaptics"
  Identifier    "Mouse1"
  Option        "Device"                "/dev/psaux"
  Option        "Protocol"              "auto-dev"
  Option        "LeftEdge"              "120"
  Option        "RightEdge"             "830"
  Option        "TopEdge"               "120"
  Option        "BottomEdge"            "650"
  Option        "FingerLow"             "14"
  Option        "FingerHigh"            "15"
  Option        "MaxTapTime"            "180"
  Option        "MaxTapMove"            "110"
  Option        "EmulateMidButtonTime"  "75"
  Option        "VertScrollDelta"       "20"
  Option        "HorizScrollDelta"      "20"
  Option        "MinSpeed"              "0.3"
  Option        "MaxSpeed"              "0.75"
  Option        "AccelFactor"           "0.015"
  Option        "EdgeMotionMinSpeed"    "200"
  Option        "EdgeMotionMaxSpeed"    "200"
  Option        "UpDownScrolling"       "1"
  Option        "CircularScrolling"     "1"
  Option        "CircScrollDelta"       "0.1"
  Option        "CircScrollTrigger"     "2"
EndSection
                                                              138,9         Bot
Comment 12 Homayoun Shahri 2005-04-25 13:42:49 EDT
I had the same problem with 2.6.11.7, and able to resolve it with either of the
following approaches.
try: (if psmosue is compiled a module, in /etc/modprobe.conf)
options psmouse proto=imps
or: (if psmouse is compiled into kernel, put the line below as kernel boot
option in grub.conf)
psmouse.proto=imps
Comment 13 Avi Jacobson 2005-04-26 00:19:38 EDT
(In reply to comment #12)
> I had the same problem with 2.6.11.7, and able to resolve it with either of 
the
> following approaches.
> try: (if psmosue is compiled a module, in /etc/modprobe.conf)
> options psmouse proto=imps
> or: (if psmouse is compiled into kernel, put the line below as kernel boot
> option in grub.conf)
> psmouse.proto=imps

Thanks, Doctor Shahri. This worked a charm! 

--
Avi Jacobson, avi-j@pacbell.net
Comment 14 Chris Elmquist 2005-04-27 11:05:06 EDT
experience same on Dell 600m.

from dmesg:

mice: PS/2 mouse device common for all mice
input: AT Translated Set 2 keyboard on isa0060/serio0
ALPS Touchpad (Glidepoint) detected
  Disabling hardware tapping
input: AlpsPS/2 ALPS TouchPad on isa0060/serio1

have not had a chance to try suggested fixes.  Just reporting another affected
platform.
Comment 15 Kyle Pablo 2005-06-14 16:33:57 EDT
hello,

I am running FC4 after upgrade and my mouse is also detected as:

input: DualPoint Stick on isa0060/serio1
input: AlpsPS/2 ALPS DualPoint TouchPad on isa0060/serio1

and it is way too jumpy as described by everyone else.  I have a dell inspiron 8200.

my xorg.conf is:

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5"
        Option      "Emulate3Buttons" "yes"
EndSection
Comment 16 Kyle Pablo 2005-06-16 22:09:59 EDT
hello,

i added psmouse.proto=exps
 to my grub.conf file and that fixed the problem for my alps touchpad on fc4.

Kyle
Comment 17 Clive Long 2005-07-01 03:45:23 EDT
Same mouse / touchpad behaviour here.

2.6.11 kernel "Jerky". "Over-sensitive" - responding as if "clicked" on buttons
- even if I haven't - hence unwanted launching of applications or menu options.

Mouse performance fine under 2.6.10 kernel.

Log info below:

Jun 29 08:00:39 localhost syslogd 1.4.1: restart.
Jun 29 08:00:39 localhost syslog: syslogd startup succeeded
Jun 29 08:00:39 localhost kernel: klogd 1.4.1, log source = /proc/kmsg started.
Jun 29 08:00:39 localhost kernel: Linux version 2.6.11-1.27_FC3
(bhcompile@porky.build.redhat.com) (gcc version 3.4.3 20050227 (Red Hat
3.4.3-22)) #1 Tue May 17 20:27:37 EDT 2005
Jun 29 08:00:39 localhost kernel: BIOS-provided physical RAM map:
Jun 29 08:00:39 localhost kernel:  BIOS-e820: 0000000000000000 -
000000000009f400 (usable)
Jun 29 08:00:39 localhost kernel:  BIOS-e820: 000000000009f400 -
00000000000a0000 (reserved)
Jun 29 08:00:39 localhost kernel:  BIOS-e820: 00000000000d0000 -
00000000000d8000 (reserved)
Jun 29 08:00:39 localhost kernel:  BIOS-e820: 00000000000e4000 -
0000000000100000 (reserved)
Jun 29 08:00:39 localhost kernel:  BIOS-e820: 0000000000100000 -
000000001fdf0000 (usable)
Jun 29 08:00:39 localhost kernel:  BIOS-e820: 000000001fdf0000 -
000000001fdfb000 (ACPI data)
Jun 29 08:00:39 localhost kernel:  BIOS-e820: 000000001fdfb000 -
000000001fe00000 (ACPI NVS)
Jun 29 08:00:39 localhost kernel:  BIOS-e820: 000000001fe00000 -
0000000020000000 (reserved)
Jun 29 08:00:39 localhost kernel:  BIOS-e820: 00000000fec00000 -
00000000fec10000 (reserved)
Jun 29 08:00:39 localhost syslog: klogd startup succeeded
Jun 29 08:00:39 localhost kernel:  BIOS-e820: 00000000fee00000 -
00000000fee01000 (reserved)
Jun 29 08:00:39 localhost kernel:  BIOS-e820: 00000000fff80000 -
0000000100000000 (reserved)
Jun 29 08:00:39 localhost kernel: 0MB HIGHMEM available.
Jun 29 08:00:39 localhost kernel: 509MB LOWMEM available.

<< cut >>

Jun 29 08:00:42 localhost kernel: mice: PS/2 mouse device common for all mice
Jun 29 08:00:42 localhost kernel: input: AT Translated Set 2 keyboard on
isa0060/serio0
Jun 29 08:00:42 localhost kernel: ALPS Touchpad (Glidepoint) detected
Jun 29 08:00:42 localhost kernel:   Disabling hardware tapping
Jun 29 08:00:42 localhost kernel: input: AlpsPS/2 ALPS TouchPad on isa0060/serio4


<< cut >>

Jun 30 10:18:34 localhost syslogd 1.4.1: restart.
Jun 30 10:18:34 localhost syslog: syslogd startup succeeded
Jun 30 10:18:34 localhost kernel: klogd 1.4.1, log source = /proc/kmsg started.
Jun 30 10:18:34 localhost kernel: Linux version 2.6.11-1.27_FC3
(bhcompile@porky.build.redhat.com) (gcc version 3.4.3 20050227 (Red Hat
3.4.3-22)) #1 Tue May 17 20:27:37 EDT 2005
Jun 30 10:18:34 localhost kernel: BIOS-provided physical RAM map:
<< cut >>
Jun 30 10:18:36 localhost kernel: mice: PS/2 mouse device common for all mice
Jun 30 10:18:36 localhost kernel: input: AT Translated Set 2 keyboard on
isa0060/serio0
Jun 30 10:18:36 localhost kernel: ALPS Touchpad (Glidepoint) detected
Jun 30 10:18:36 localhost kernel:   Disabling hardware tapping
Jun 30 10:18:36 localhost kernel: input: AlpsPS/2 ALPS TouchPad on isa0060/serio4
Jun 30 12:01:01 localhost crond(pam_unix)[18644]: session opened
Comment 18 Dave Jones 2005-07-15 14:06:56 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 19 Fulko Hew 2005-07-15 23:07:50 EDT
Problem is now resolved on my hw with the new kernel: 2.6.12-1.1372_FC3.
Comment 20 Adam Bowns 2005-07-16 12:14:37 EDT
psmouse.proto=imps fixed it with the old kernels.

kernel-2.6.12-1.1372_FC3 works fine even without adding this line. Looks like
the bug’s been fixed.
Comment 21 Aaron Gaudio 2005-07-16 16:10:11 EDT
I'm currently using a vanilla 2.6.12 kernel with swsusp2 patch added so I can
hibernate, so I can't test this for the exact redhat kernel. I'll take the
others' word for it that it is fixed.
Comment 22 Peter K 2005-07-18 05:07:04 EDT
I no longer have that hardware so I can not verify the fix.
Comment 23 Aaron Gaudio 2005-07-20 15:07:28 EDT
One last thing- after testing the synaptics driver in 2.6.12+swsusp2, I am
unable to configure Xorg to use the synaptics driver, following the directions
for the synaptics rpm (in the docs). When I try to use "auto-dev" or "synaptics"
as the Driver for the input device, Xorg tells me "unknown driver", though I can
see that the .so provided by the synaptics rpm is indeed installed.
Comment 24 Mark Wilkinson 2005-07-21 04:47:09 EDT
Hmm; I'm still seeing problems with the updated kernel on FC3, although not the
same problem as before:

1) Click-drag doesn't work. This is most notable for window title-bars. With the
old drivers (or with psmouse.proto=imps2 on the kernel command line) a tap
followed by a drag starts a window drag. With the new driver this doesn't work.

2) ACPI suspend/resume stops the pointing device from working, as reported by
others (https://www.redhat.com/archives/fedora-list/2005-June/msg02707.html and
bug #161546). On my system (Dell Lattitude D600) even a reboot won't bring it
back - I have to do a  full power-off shutdown and reboot.

psmouse.proto=imps2 doesn't exhibit either of these problems.

Reopen, or file a new bug for the click/drag problem?
Comment 25 Aaron Gaudio 2005-07-21 10:04:13 EDT
The click-to-drag behavior is supposed to be configurable, either from sysctl
(don't know the settings) or from xorg.conf. I've tried the latter, using the
synaptics X driver, but as mentioned above was unable to get it to recognize the
protocol...
Comment 26 Donald King 2005-07-30 10:26:45 EDT
Additional manifestation of the problem on a Dell D800 running 2.6.11-1.27_FC3.

The buttons associated with the stick do not work at all.

I can't upgrade to 2.6.12-1.1372_FC3 because that release doesn't contain the
build directory under /lib/module/2.6.12-1.1372_FC3/ (it is a link to the source
directory that is not in the binary rpm) so I can't rebuild the NVidia drivers.
Comment 27 Adam Bowns 2005-07-31 10:38:56 EDT
Donald, There was a slight change in the packaging of the kernel in the last
update, if you install the kernel-devel package you should be able to build your
nvidia driver as usual. The next kernel update should take things back to the
way things used to be, so FC3 won’t need the kernel-devel package to build
modules, but it does for now.

Some more info can be found over at bug 163406
Comment 28 Kai 'wusel' Siering 2005-08-10 23:51:40 EDT
(In reply to comment #18)
> An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3)[...]
> 
> If you have updated to Fedora Core 4 since this bug was opened, and the problem
> still occurs with the latest updates for that release

Problem still exists in 2.6.12-1.1398_FC4 for me: Mouse is painfully slow and
does not react in any way to acceleration settings in "Mouse Preferences". In
that setup, FC4 is not usable on my Laptop (Sony Z600NE).

psmouse.proto=imps in grub.conf makes the touchpad usable for me -- thanks a
lot to the original poster of this workaround!

> please change the version field of this bug to 'fc4'.

Can't: »You tried to change the Version field from fc3 to fc4, but only the
owner or submitter of the bug, or a sufficiently empowered user, may change
that field.«
Comment 29 Aaron Gaudio 2005-08-11 10:00:50 EDT
I'm the original reporter, and I have upgraded to FC4 and kernel 2.6.12. I
haven't seen any reply to my comment about the synaptics X driver not appearing
to work. The performance problems have gone away, but without being able to
configure the synaptics driver, I still have to revert to the imps workaround
because I want to be able to tap-click. 

Aside from Kai's apparently problems, it seems the original performance problems
have been resolved for everyone attached to this bug. Unless there are any
objections, I'm satisfied with re-closing this and opening a more specific bug
wrt the synaptics driver (and Mark, if you're still having ACPI issues, I
suggest you write those up as well).
Comment 30 Dave Jones 2005-08-11 18:28:59 EDT
Ok, there are a number of other bugs open iirc related to touchpad, if any of
you are still seeing problems, check if any of those apply to you, and if not,
please open a new bug.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.