Bug 153221 - focus-follows-mouse problems with tabbed apps
focus-follows-mouse problems with tabbed apps
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
:
: 149327 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-03 12:09 EDT by John Ellson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-18 13:08:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2005-04-03 12:09:41 EDT
Description of problem:
Havoc suggests that there is a Gtk problem here:

http://bugzilla.gnome.org/show_bug.cgi?id=117240
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=149327

For example:  focus-follows-mouse into tabbed gnome-terminals unless
there is a dotted box in the tab.  The dotted box can be obtained
by double-clicking on the tab, which is perhaps intended behavior, but also
by click-drag on the tab such as by slight motion of the mouse when the user is
selecting the tab.

The user is then surprised that text entry doesn't work in the terminal area
even though the mouse is over the main terminal window.  This is still true
even after the mouse leaves the terminal altogether and then returns.

Epiphany tabs exhibit the same behavior, but it matters less there because the
user is not expecting to enter text into the main window.

Version-Release number of selected component (if applicable):
gtk2-2.6.4-2

How reproducible:
100%

Steps to Reproduce:
1.Desktop->Preferences->Windows->"Select windows when the mouse moves over them"
2.gnome-terminal with multiple tabs 
3.click-drag over the currently active tab (not doubleclick)
  
Actual results:
No focus in the main terminal area

Expected results:
Focus follows mouse into the main terminal area of gnome-terminal

Additional info:
Comment 1 Matthias Clasen 2005-08-18 09:55:50 EDT
Please don't jump bugzillas like this. If there is a genuine GTK+ problem,
it needs to be filed upstream at bugzilla.gnome.org
Comment 2 John Ellson 2005-08-18 11:31:45 EDT
I don't know what "jump bugzilas" means.   The Fedora user needs a single place
to file bugs.  If it needs to go somehere else then thats a triage issue.
Comment 3 Matthias Clasen 2005-08-18 11:49:36 EDT
I meant that this issue seems to have started as a bug in Fedora bugzilla,
jumped to gnome bugzilla, then jumped back to Fedora bugzilla.
Comment 4 John Ellson 2005-08-18 12:04:51 EDT
Its hard to recall since this was reported over a year ago.

I think I first reported a problem against gnome terminal.
   https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=149327
but then wanted to ensure it was also reported agains gtk2 in Redhat's
Bugzilla (this report) as gtk2 seemed more likely to be the problem.

I did not jump any bugzilla's.  I just added a reference to a possibly related
problem in gnome's bugzilla.

The problem still exists today in Fedora, so this bug should not be closed.
If triage has forwarded it upstream, then a status of something like "pending
upstream" would be OK, but not "closed" or other users will not be able to find
that the issue is already being investigated.

Comment 5 Matthias Clasen 2005-08-18 13:08:11 EDT
In an ideal world maybe. But in reality, the day only has 24 hours, and genuine
gtk bugs (as opposed to packaging bugs) are tracked upstream in gnome bugzilla.
I don't want them to clog up my fedora/rhel bug lists.
Comment 6 Ray Strode [halfline] 2005-08-31 12:20:32 EDT
*** Bug 149327 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.