Bug 1532252 - Account settings segfault when run under root
Summary: Account settings segfault when run under root
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: accountsservice   
(Show other bugs)
Version: 7.5
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: 7.5
Assignee: Ray Strode [halfline]
QA Contact: Desktop QE
URL:
Whiteboard:
Keywords: Regression
: 1539536 1539601 (view as bug list)
Depends On:
Blocks: 1438583 1454909 1527213 1544369
TreeView+ depends on / blocked
 
Reported: 2018-01-08 13:39 UTC by Jiri Koten
Modified: 2018-05-17 14:39 UTC (History)
6 users (show)

Fixed In Version: accountsservice-0.6.45-5.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1544369 (view as bug list)
Environment:
Last Closed: 2018-04-10 13:10:18 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace (15.83 KB, text/plain)
2018-01-08 13:39 UTC, Jiri Koten
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0770 None None None 2018-04-10 13:11 UTC

Description Jiri Koten 2018-01-08 13:39:59 UTC
Created attachment 1378523 [details]
backtrace

Description of problem:
Running gnome-control-center user-accounts under root results in segfault.

The crash is probably related to unlocking of dialogs in the control-settings which require root privileges.

Version-Release number of selected component (if applicable):
control-center-3.26.2-3.el7


How reproducible:
100%

Steps to Reproduce:
1. Log in to gnome session under root
2. run Account Settings
3.

Actual results:
Crash

Expected results:
No crash

Additional info:

Comment 5 Jiri Koten 2018-01-29 10:39:50 UTC
*** Bug 1539601 has been marked as a duplicate of this bug. ***

Comment 6 Jiri Koten 2018-01-29 14:27:43 UTC
*** Bug 1539536 has been marked as a duplicate of this bug. ***

Comment 7 Ondrej Holy 2018-01-30 08:32:34 UTC
As per the backtrace, this is a consequence of changes from Bug 1474579 and I suppose that the following patch for accountsservice should fix it. Thus moving this bug into accountsservice component.
https://bugs.freedesktop.org/show_bug.cgi?id=104851

However, control-center may also segfault in certain cases if run under root, but I suppose that this is not a regression, but rather a long-term issue. Anyway, the patches from the following bug should fix it also. Please file another bug report if it is desired.
https://bugzilla.gnome.org/show_bug.cgi?id=773673

Comment 9 Jiri Koten 2018-02-12 10:03:29 UTC
The crash in accountsservice is fixed. But we need to fix also the consequent crash in g-c-c to fully fix the crash when run under root. Thus moving this bug to verified and cloning it for g-c-c.

Comment 12 errata-xmlrpc 2018-04-10 13:10:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0770


Note You need to log in before you can comment on or make changes to this bug.