Bug 153229 - upgrade to rawhide not working
upgrade to rawhide not working
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-03 14:02 EDT by Havoc Pennington
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: 1.9.93-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-25 03:56:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Havoc Pennington 2005-04-03 14:02:23 EDT
It looks like yum can't figure out to go 
from "openoffice.org" installed to installing the new split-apart packages.

One solution might be an "openoffice.org" package that's empty but requires the
new split-up packages... I don't know if that's the best one though.
Comment 1 Caolan McNamara 2005-04-03 15:07:36 EDT
And if you have old i18n installed then you need to get the 23 (or whatever it
actually is) langpacks installed as well. What happened in the past when
previous packages got split into sub-packages ?

Though you say "not working", the new openoffice.org-core package Obsoletes all
the old openoffice.org packages so yum should know to remove the old Obsolete
stuff and just install the new core on its own to replace the lot. Is this not
happening in practice ?
Comment 2 Havoc Pennington 2005-04-04 18:22:12 EDT
The answer to "what happened in the past" is that we usually add some custom
hack or fool with dependencies to work around it. There is no clean solution.

IIRC the "not working" in this case was that a "yum update" would fail because
it needed to update OO.org in order to resolve dependencies (since old OO.org
required some old thing it needed to uninstall) and failed to do so.

Maybe you need both Obsoletes and Provides?

Jeremy what's your advice?
Comment 3 Jeremy Katz 2005-04-04 22:01:00 EDT
I sent mail about this to caolanm and dcbw right after 1.9.x went in saying we
needed to sit down and talk about the right set of obsoletes/provides to get
this to work right.  Basically, I think that 'Obsoletes: openoffice.org' on all
of the "main" packages and 'Obsoletes: openoffice.org-i18n' on the "langpack"
packages should do what we want.  But it'll need testing (which we can do by
making dummy empty packages named the same to try the upgrade path with instead
of having to build OOo itself a dozen times)

But I probably won't have a chance to try this until after I get back from the UK.  
Comment 4 Caolan McNamara 2005-04-05 04:12:35 EDT
Here's what I get when I have openoffice.org 1.1.X installed and do a yum
update, i end up with openoffice.org 1.1.X uninstalled and openoffice.org-core
1.9.X installed instead as I intended. So just to be clear, is this 
a) not happening for others, or...
b) just not the desired behaviour ?

> rpm -q openoffice.org
openoffice.org-1.1.3-9.5.0.fc3
> rpm -q openoffice.org-libs
openoffice.org-libs-1.1.3-9.5.0.fc3
> yum -y update
Dependencies Resolved
Transaction Listing:
  ...
  Install: openoffice.org-core.i386 1:1.9.89-1 - development
  ...

Running Transaction
  ...
  Obsoleting: openoffice.org-core          #####################
  ...
  Removing  : openoffice.org               #####################
  Removing  : openoffice.org-libs          #####################
  ...

Installed: ... openoffice.org-core.i386 1:1.9.89-1
Obsoleted: ... openoffice.org.i386 0:1.1.3-9.5.0.fc3 openoffice.org-libs.i386
0:1.1.3-9.5.0.fc3
Complete!
> rpm -q openoffice.org-core
openoffice.org-core-1.9.89-1
Comment 5 Jeremy Katz 2005-04-05 11:39:53 EDT
Since that doesn't actually let you run what you could before the upgrade (you
need to still install -impress, -writer, etc plus if you had the -i18n package
installed before, you don't have equivalent functionality), it's not the desired
behavior.
Comment 6 Caolan McNamara 2005-04-21 12:15:26 EDT
should work in the next rpm

Note You need to log in before you can comment on or make changes to this bug.