Bug 153290 - OOdraw creates a new instance incorrectly
OOdraw creates a new instance incorrectly
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-04 10:50 EDT by Paul F. Johnson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-05 06:19:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
First picture (9.61 KB, application/vnd.oasis.opendocument.graphics)
2005-04-05 05:48 EDT, Paul F. Johnson
no flags Details
Picture 2 (10.40 KB, application/vnd.oasis.opendocument.graphics)
2005-04-05 05:49 EDT, Paul F. Johnson
no flags Details

  None (edit)
Description Paul F. Johnson 2005-04-04 10:50:11 EDT
Description of problem:
If you open an OOo draw diagram up when draw is already open, another window
instance is created, but the diagram is also loaded into any other draw windows
as a new page.

Version-Release number of selected component (if applicable):
1.9.89-1

How reproducible:
Always

Steps to Reproduce:
1. Open an OOdraw diagram
2. Open another
3.
  
Actual results:
The drawing creates a new window instance, but the diagram is copied into the
first as a new page

Expected results:
The diagram should not create a new window instance, rather replace the original
diagram

Additional info:
Comment 1 Caolan McNamara 2005-04-05 05:27:51 EDT
You know I can't reproduce this either. Give absolutely precise instructions, 
how draw is initially started, e.g. oodraw from the command line, clicking on a
.odg document from nautilus, file new-> from a writer shell. Then if you are
starting off with a blank oodraw, or from an oodraw which has something drawn in
it. Clearly what should happen is that if you have a blank oodraw shell where
nothing has been drawn, then file open etc will open the new document in the
current shell, if something has been drawn then it gets opened in a new shell.
You seem to suggest that if something is opened in a new shell that something
changes in the old shell, a page gets added. I don't see this, so can you even
attach the first drawing, the second drawing and a screenshot of what goes wrong
in the first shell when the 2nd drawing is opened.

C.
Comment 2 Paul F. Johnson 2005-04-05 05:47:09 EDT
oodraw is opened via oowriter (open->new doc->drawing) usually, but the same
results come from the command line.

If I create a drawing, save and delete then open an already created picture, a
new window is created. The original is blank, but two windows appear under the
"window" menu item.
Comment 3 Paul F. Johnson 2005-04-05 05:48:47 EDT
Created attachment 112707 [details]
First picture

This is a typical first picture. Start OO draw via OOwriter and open this file.
Save it. Select and delete. Load in the next attachment. It will be opened in a
new window rather than in the blank one.
Comment 4 Paul F. Johnson 2005-04-05 05:49:15 EDT
Created attachment 112708 [details]
Picture 2

Second picture
Comment 5 Caolan McNamara 2005-04-05 06:19:07 EDT
By select and delete I assume you mean you select the contents of the drawing
and delete. Opening the next document in a new window is intentional, when you
start off with the initial blank oodraw, no document is loaded, so when you load
one it takes over the oodraw shell which is not associated with any document.
Once a document is opened in a shell, even when you delete it's contents after
saving, it's still associated with the document to which is was saved, or loaded
if not saved yet. So when you open a new document it opens in a new shell. If
you are finished with a document you close it with the [x] close and open a new
one that way if you don't want two documents open at a time.

Note You need to log in before you can comment on or make changes to this bug.