Bug 153300 - RHEL5-rg-bug: Multiple minor corrections / typos in rhel-rg
RHEL5-rg-bug: Multiple minor corrections / typos in rhel-rg
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rhel-rg (Show other bugs)
4.5
All Linux
medium Severity low
: ---
: ---
Assigned To: Michael Hideo
John Ha
http://www.redhat.com/docs/manuals/en...
: Documentation
Depends On:
Blocks: 148897
  Show dependency treegraph
 
Reported: 2005-04-04 12:35 EDT by Stephen Gardner
Modified: 2014-08-04 18:15 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHEL4.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-23 21:39:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gardner 2005-04-04 12:35:37 EDT
Version-Release number of selected component (if applicable):
RHEL4-Reference Guide
Version: rhel-rg(EN)-4-HTML-RHI (2004-09-30T17:13)

1.4.2   Runlevel Utilities

        Error Type: incorrect command location
        Priority: medium

            /sbin/ntsysv   is now located at   /usr/sbin/ntsysv

        [ no symlink exists either, this old location was correct in RHEL3 ]
        [ appears elsewhere in rhel-rg, search for /sbin/ntsysv throughout ]
        [ ntsysv referred to inconsistently within the rhel-rg with and    ]
        [ without path prefix                                              ]

2.6     Grub Commands, Paragraph detailing "kernel" option

        Error Type: consistency
        Priority: low

            paragraph should probably refer to 
            "root=/dev/VolGroup00/LogVol00"  not  "/dev/hda5" or "hda5"
            and examples should be
            "kernel /vmlinuz-2.6.8-1.523 ro root=/dev/VolGroup00/LogVol00"
            to be consistent with Section 2.7.1 et al.

            Removal of references to kernel version 2.4.21 throughout.


3.2.1.14 The /var/ Directory

        Error Type: typo
        Priority: ultra-low

            "System log files, such as messages/ and lastlog/"   probably should
be changed to 
            "System log files, such as messages and lastlog"

            because these are filenames not directory names.


5.3.9.3  /proc/sys/kernel

        Error Type: non-default option referred to
        Priority: low

            Under "cap-bound" (and other sections) of the documentation 
            says
            
            "For a valid list of values for this virtual file, refer to the 
            following installed documentation:
            /lib/modules/<kernel-version>/build/include/linux/capability.h."

        The file referred to is part of the kernel-devel package which is 
        not part of the default installation set. The statement should 
        include a reference to the kernel-devel package


5.3.9.4 /proc/sys/net

        Error Type: reference to unsupported option
        Priority: ultra-low

            "such as appletalk/, ethernet/, ipv4/"..  should change to 
            "such as ethernet/, ipv4/"..

        RHEL4 does not support appletalk and even though this is only an 
        example people who use appletalk may go looking for appletalk elsewhere 
        in the docs.


14.9.4. Useful Websites

        Error Type: Specific version number should be made generic
        Priority: ultra-low

            "samba-3.0.3"...   replace with 
            "samba-<versionnumber>"...

        For reference RHEL4 ships with 3.0.10.


17.1    TCP Wrappers

        Error Type: Bad example in Note section
        Priority: medium

           The Note for determining if a network service users TCP wrappers is
outdated as 
           most RHEL4 service are dynamically (not statically) linked with TCP
wrappers.
           
           The example
               "strings -f <binary-name> | grep hosts_access"

           won't detect all services which use TCP wrappers. Perhaps 
           
           ldd <binary-name> |grep libwrap
           
           would I believe catch a high proportion of wrappered services
           but neither method is 100%.


19.5    Configuring a Kerberos 5 Server (paragraph numbered 1.)

        Error Type: Old URL used
        Priority: low

           The official home page for NTP has changed from 
           http://www.eecis.udel.edu/~ntp     to
           http://www.ntp.org


20.6    Requiring SSH for Remote Connections

        Error Type: Old reference
        Priority: ultra-low

            redhat-config-services   change to
            system-config-services

         I think this has happened everywhere else in the docs.


A.3. Ethernet Parameters

        Error Type: Old reference
        Priority: ultra-low

            modules.conf   should be replaced with   modprobe.conf


Document Wide:
         You could consider search for "2.6.8-1.523" and aim to replace 
         them with "2.6.9-5.EL" throughout as that's the kernel version 
         RHEL4-U0 shipped with but I realise its almost always used as 
         an example.
Comment 2 Mike Behm 2006-02-06 09:30:24 EST
All requested changes have been made except for:

5.3.9.3  /proc/sys/kernel

        Error Type: non-default option referred to
        Priority: low

            Under "cap-bound" (and other sections) of the documentation 
            says
            
            "For a valid list of values for this virtual file, refer to the 
            following installed documentation:
            /lib/modules/<kernel-version>/build/include/linux/capability.h."

        The file referred to is part of the kernel-devel package which is 
        not part of the default installation set. The statement should 
        include a reference to the kernel-devel package

>> Can you suggest an appropriate package?

Another change not yet made is this:

Document Wide:
         You could consider search for "2.6.8-1.523" and aim to replace 
         them with "2.6.9-5.EL" throughout as that's the kernel version 
         RHEL4-U0 shipped with but I realise its almost always used as 
         an example.

>> Are there kernel changes between updates that make such changes difficult
>> to maintain properly?
Comment 3 Don Domingo 2007-04-16 03:07:41 EDT
fixes verified in source. reassigning to mhideo to have updated built document
pushed to docs site. 

thanks!
Comment 4 Don Domingo 2007-05-28 21:26:04 EDT
changing to MODIFIED, to be CLOSEDCURRENTRELEASE when pushed to docs site
Comment 5 Michael Hideo 2007-10-22 22:50:34 EDT
Removing automation notification

Note You need to log in before you can comment on or make changes to this bug.