Bug 15348 - While doing an FTP upgrade from 6.2 to 7.0 beta 5.
While doing an FTP upgrade from 6.2 to 7.0 beta 5.
Status: CLOSED DUPLICATE of bug 15302
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-03 23:28 EDT by Kimo Bonnelycke
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-08 12:17:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Server Install Log (6.51 KB, text/plain)
2000-08-05 15:59 EDT, Kimo Bonnelycke
no flags Details
What I currently have installed. (5.02 KB, text/plain)
2000-08-05 16:01 EDT, Kimo Bonnelycke
no flags Details

  None (edit)
Description Kimo Bonnelycke 2000-08-03 23:28:45 EDT
I get the following error when doing an FTP upgrade.  The installation 
appears to be going fine, and over 300 packages area installed, but the 
same error occurs while trying to install the "kernel-2.2.16-17".

Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 426, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/text.py", line 1022, in run
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/text.py", line 504, in 
__call__
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/todo.py", line 1522, in 
doInstall
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/todo.py", line 1265, in 
instCallback
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/urlinstall.py", line 47, 
in getFilename
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/log.py", line 23, in 
__call__
TypeError: illegal argument type for built-in operation

Local variables in innermost frame:
args: ('ftp error', 'ftp://tjnit:%61%6d%69%67%61%31%6b%69%6d%
6f@10.0.0.254/storage/cdrom1/RedHat/base/hdlist', <exceptions.IOError 
instance at 99723c0>)
self: <log.LogFile instance at 81df9e0>
format: IOError %d occured getting %s: %s

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iurlinstall
UrlInstallMethod
p4
(dp5
S'baseUrl'
p6
S'ftp://tjnit:%61%6d%69%67%61%31%6b%69%6d%6f@10.0.0.254/storage/cdrom1'
sbsS'initlevel'
p7
I3
sS'skipLilo'
p8
I0
sS'progressWindow'
p9
(itext
ProgressWindow
(dp10
S'scale'
p11
(isnack
Scale
(dp12
S'w'

Kimo Bonnelycke (please contact me if you have any questions)
Comment 1 Kimo Bonnelycke 2000-08-04 10:40:14 EDT
Just a NOTE:  The actual version of RedHat that I was installing was 6.9.5.

Thank You,

Kimo Bonnelycke
Comment 2 Kimo Bonnelycke 2000-08-04 21:19:45 EDT
I read (Bug #15351) and decided to retry the install, but only install the 
Server Image, and the install went great.  So I also did a custom install, and 
just selected some packages, and the install failed with the same anaconda 
error.  This time it failed at package "kdeadmin-1.92.2000".  So I just 
reinstalled the Server Image, and am going to install individual packages one 
at a time..

Kimo Bonnelycke
Comment 3 Kimo Bonnelycke 2000-08-04 22:21:50 EDT
I was able to add all the XFree and KDE components to the Server Installation, 
and everything is running fine.  I will post more updates, as I continue to 
test.

Kimo Bonnelycke
Comment 4 Kimo Bonnelycke 2000-08-05 16:00:00 EDT
Created attachment 2115 [details]
Server Install Log
Comment 5 Kimo Bonnelycke 2000-08-05 16:01:17 EDT
Created attachment 2116 [details]
What I currently have installed.
Comment 6 Pekka Savola 2000-08-07 03:37:28 EDT
FWIW, a couple of FTP upgrades 6.2 -> 7.0beta5 have went just fine in here. 
Using text
mode though.
Comment 7 Michael Fulbright 2000-08-08 12:17:16 EDT

*** This bug has been marked as a duplicate of 15302 ***

Note You need to log in before you can comment on or make changes to this bug.