Bug 153678 - FC3 test update needs libtool update (!)
FC3 test update needs libtool update (!)
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-04 17:50 EDT by Michael Schwendt
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-13 13:56:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2005-04-04 17:50:20 EDT
GCC Test Update for FC3 breaks libtool's requirement (hence I file this here):

  Error: Missing Dependency: gcc = 3.4.2 is needed by package libtool

Version-Release number of selected component (if applicable):
gcc-3.4.3-22.fc3
Comment 1 Jakub Jelinek 2005-04-04 17:53:14 EDT
You must have missed libtool-1.5.6-4.FC3.2 in 3/updates/testing/ (same place
as the GCC testing update).
Comment 2 Chris Underhill 2005-04-12 15:49:58 EDT
gcc updates have gone into the non-test directory today and the updated libtool
is not present. The latest version on the fedora server is
libtool-1.5.6-4.FC3.1. This results in the error message

Missing Dependency: gcc = 3.4.2 is needed by package libtool

when I run up2date.
Comment 3 Myk Melez 2005-04-12 17:08:08 EDT
I checked Fedora updates ten minutes ago, and it had the old version of the
file.  I checked it again just now, and it now has the new version.  Looks like
it just got pushed.  Wait a day or so and it should show up on the mirrors.

http://download.fedora.redhat.com/pub/fedora/linux/core/updates/testing/3/i386/
Comment 4 Sigurd Hogsbro 2005-04-12 21:38:33 EDT
I think Myk is looking at testing, and thus missed the point made by Chris
Underhill. 

The stable/updates branch is missing the correct version of libtool. I just
tried yum update against the main servers, and still got the same error. Can
someone with priviledges push the libtool update thru? 
Comment 5 Myk Melez 2005-04-12 22:14:04 EDT
Urk, I was indeed looking at testing by mistake.  Sigurd is correct; the
stable/updates branch is still missing the libtools update, without which the
gcc updates released today fail.

http://download.fedora.redhat.com/pub/fedora/linux/core/updates/3/i386/
Comment 6 Michael Schwendt 2005-04-13 13:56:49 EDT
My original report was about updates-testing, where I couldn't get yum to see
the included libtool update until after half a dozen retries. Closing this
again, since the final FC3 Update has been fixed.

Note You need to log in before you can comment on or make changes to this bug.