This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 153713 - restorecon should be conditional
restorecon should be conditional
Status: CLOSED DUPLICATE of bug 153100
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-05 02:21 EDT by Robert Scheck
Modified: 2014-03-16 22:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-05 14:06:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2005-04-05 02:21:03 EDT
Description of problem:
Like everything SELinux specific in initscripts, restorecon should be also made
conditional (onliest missing currently).

Version-Release number of selected component (if applicable):
initscripts-8.07-1

Actual results / Expected results:
--- initscripts-8.07/rc.d/rc.sysinit       2005-03-28 22:29:11.000000000 +0200
+++ initscripts-8.07/rc.d/rc.sysinit.rsc   2005-04-05 08:01:44.000000000 +0200
@@ -593,7 +593,7 @@
 fi

 # Clean up various /tmp bits
-restorecon /tmp
+[ -n "$SELINUX" ] && restorecon /tmp
 rm -f /tmp/.X*-lock /tmp/.lock.* /tmp/.gdm_socket /tmp/.s.PGSQL.*
 rm -rf /tmp/.X*-unix /tmp/.ICE-unix /tmp/.font-unix /tmp/hsperfdata_* \
        /tmp/kde-* /tmp/ksocket-* /tmp/mc-* /tmp/mcop-* /tmp/orbit-*  \
Comment 1 Bill Nottingham 2005-04-05 14:06:29 EDT

*** This bug has been marked as a duplicate of 153100 ***

Note You need to log in before you can comment on or make changes to this bug.