Bug 153744 - BIOS display sleep causes screen to scramble
BIOS display sleep causes screen to scramble
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-05 11:40 EDT by Andrew D. Stadler
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-11 15:04:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 2974 None None None Never

  None (edit)
Description Andrew D. Stadler 2005-04-05 11:40:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
The Thinkpad T30 BIOS includes a 'display sleep' setting to save battery life & screen backlight life.  This appears to be independent of the screensaver settings.

Unfortunately if this display sleep kicks in, X does not recover properly.  When you click any key (e.g. SHIFT) to 'wake up' the screen, it comes up in a scrambled, jumpy, unuseable condition.  I have found that logging out and logging in X do not fix it.  The only solution that appears to fix it (other than a reboot) is /usr/bin/apm -s

The only way I have found to avoid this problem is to use BIOS settings to disable sleep entirely.  But this has the unfortunate side effect of losing a useful feature.

Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-1.FC3.13   & IBM BIOS 2.08

How reproducible:
Always

Steps to Reproduce:
1.  Boot laptop into BIOS setup screen
2.  Adjust display sleep (both AC and battery) to short but different durations (e.g. 1 minute and 3 minutes)
3.  Save settings and boot into Linux
4.  Wait with AC power until display sleeps, hit shift to wake up, notice scrambling
5.  Recover using sleep or reboot
6.  Repeat 4 with battery power
  

Actual Results:  Display wakes up in a scrambled, unuseable mode

Expected Results:  Display wakes up normally

Additional info:

Note, this problem also seems to be affected by the existence of a 2nd monitor in dual-head mode.  I have not seen the problem when I have two monitors plugged in - for some reason, in this configuration, the LCD does sleep, and it does wake, properly.  

I always see the problem when I only have the internal laptop monitor.

My system is a ThinkPad T30 running FC3, pretty much up-to-date.  It
has a radeon 7500 and the displays are the internal 1400x1050 and an
external VGA dell 2000fp (1600x1200).
Comment 1 Mike A. Harris 2005-04-11 07:46:57 EDT
Please file a bug report in X.Org bugzilla to track this issue,
which is located at http://bugs.freedesktop.org in the "xorg" component.

Once you've filed your report to X.Org, if you paste the URL here,
Red Hat will track the issue in X.Org bugzilla with upstream developers,
and will review any fixes that become available for potential inclusion
in future Fedora Core updates.
Comment 2 Mike A. Harris 2005-04-11 07:47:29 EDT
Setting status to "NEEDINFO", awaiting upstream bug URL for tracking.
Comment 3 Andrew D. Stadler 2005-04-11 12:21:13 EDT
<https://bugs.freedesktop.org/show_bug.cgi?id=2974>
Comment 4 Mike A. Harris 2005-04-11 15:04:59 EDT
Thanks.  Setting status to "UPSTREAM" for tracking.

Note You need to log in before you can comment on or make changes to this bug.