Bug 15383 - Netscape dies when trying to edit preferences
Summary: Netscape dies when trying to edit preferences
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: netscape   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-04 13:05 UTC by Asbjxrn Sfbx
Modified: 2014-03-17 02:15 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-09 08:10:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Asbjxrn Sfbx 2000-08-04 13:05:36 UTC
When trying to acess the function Edit -> Preferences from the menu,
Netscape dies, and disappears immediately.

netscape-navigator-4.74-0.6.2 and netscape-common-4.74-0.6.2 installed on
an Intel Pentium 166 w/64MB RAM, 500MB of swap, IDE hard drive and CDROM,
SCSI hard drive and CDROM-burner.
RedHat 6.2, manually updated from RedHat 6.1.
Kernel: kernel-2.2.16-3 from RedHat

Comment 1 Bill Nottingham 2000-08-04 18:51:59 UTC
Does this happen consistently?

What happens if you run 'LANG=C netscape'?

Comment 2 Asbjxrn Sfbx 2000-08-08 07:18:02 UTC
It seems to happen consistenly, yes.  Since I installed the new netscape
packages (and upgraded the system to RH6.2) netscape has crashed _every_ time I
have tried to access Edit->Preferences.

'LANG=C netscape' also crashes, without an error message.

However, today I have seen something that I did not observe last week.  When
doing just 'netscape' from a shell, it gives an 'bus error' when it dies. (It
did not last week.)  I get the same error message when I do an 'LANG=C' 'export
LANG' 'netscape'.

And when a netscape crashes, it takes with it other, separately started,
netscapes.

I might mention that the reason I upgraded my system was that I had gotten a
number of "oops"-es in the logs, and I tought that a newer kernel might fix
that.  However, after the weekend, the logs tells me that I am still getting
them. The issue is maybe related to this? (The oopses does not come when
netscape dies.)

"Aug  8 04:04:11 lydlab227 kernel: Unable to handle kernel paging request at
virtual address c822bdec 
Aug  8 04:04:11 lydlab227 kernel: current->tss.cr3 = 015e6000, %cr3 = 015e6000 
Aug  8 04:04:11 lydlab227 kernel: *pde = 00000000 
Aug  8 04:04:11 lydlab227 kernel: Oops: 0000"




Comment 3 Bill Nottingham 2000-08-08 14:43:58 UTC
Hm, what happens if you run the oops through
'ksymoops'?

It honestly sounds like you could be having hardware issues.

Comment 4 Asbjxrn Sfbx 2000-08-09 07:04:15 UTC
I have tried to check the hardware, releasing and resetting cards from the ISA
and PCI busses, testing the RAM in a RAM tester and so on, with no difference to
netscape.  But it may of course still be the hardware.  The oopses started a
month ago, when I was on vacation.  The netscape error I did not notice until a
week ago, when I upgraded the system, but then on the other hand it is probable
that I did not access Edit->Preferences on the old netscape after the oopses
started.

Just running ksymoops gives an error:
"Error (regular_file): read_system_map stat /usr/src/linux/System.map failed"

Trying 'ksymoops -m /boot/System.map-2.2.16-3 tmp/oops.log' gives this:

[asbjorn@lydlab227 asbjorn]$ ksymoops -m /boot/System.map-2.2.16-3 tmp/oops.log 
ksymoops 0.7c on i586 2.2.16-3.  Options used
     -V (default)
     -k /proc/ksyms (default)
     -l /proc/modules (default)
     -o /lib/modules/2.2.16-3/ (default)
     -m /boot/System.map-2.2.16-3 (specified)

Aug  8 04:04:11 lydlab227 kernel: Unable to handle kernel paging request at virt
ual address c822bdec 
Aug  8 04:04:11 lydlab227 kernel: current->tss.cr3 = 015e6000, %cr3 = 015e6000 
Aug  8 04:04:11 lydlab227 kernel: *pde = 00000000 
Aug  8 04:04:11 lydlab227 kernel: Oops: 0000 
Aug  8 04:04:11 lydlab227 kernel: CPU:    0 
Aug  8 04:04:11 lydlab227 kernel: EIP:    0010:[sys_newlstat+38/96] 
Aug  8 04:04:11 lydlab227 kernel: EFLAGS: 00010286 
Aug  8 04:04:11 lydlab227 kernel: eax: c822bda0   ebx: c1919b10   ecx: ffffffff 
  edx: c02abf90 
Aug  8 04:04:11 lydlab227 kernel: esi: c1919b10   edi: 08057fe4   ebp: bffffc38 
  esp: c0979fc0 
Aug  8 04:04:11 lydlab227 kernel: ds: 0018   es: 0018   ss: 0018 
Aug  8 04:04:11 lydlab227 kernel: Process slocate (pid: 17189, process nr: 76, s
tackpage=c0979000) 
Aug  8 04:04:11 lydlab227 kernel: Stack: c010a008 08057fe4 bffffbf8 00005ded 080
57ff0 08057fe4 bffffc38 0000006b  
Aug  8 04:04:11 lydlab227 kernel:        0000002b 0000002b 0000006b 400be94d 000
00023 00000202 bffffbe8 0000002b  
Aug  8 04:04:11 lydlab227 kernel: Call Trace: [system_call+52/56]  
Aug  8 04:04:11 lydlab227 kernel: Code: 8b 40 4c 85 c0 74 0b 53 ff d0 89 c3 83 c
4 04 eb 03 90 31 db  
Using defaults from ksymoops -t elf32-i386 -a i386

Code;  00000000 Before first symbol
00000000 <_EIP>:
Code;  00000000 Before first symbol
   0:   8b 40 4c                  mov    0x4c(%eax),%eax
Code;  00000003 Before first symbol
   3:   85 c0                     test   %eax,%eax
Code;  00000005 Before first symbol
   5:   74 0b                     je     12 <_EIP+0x12> 00000012 Before first sy
mbol
Code;  00000007 Before first symbol
   7:   53                        push   %ebx
Code;  00000008 Before first symbol
   8:   ff d0                     call   *%eax
Code;  0000000a Before first symbol
   a:   89 c3                     mov    %eax,%ebx
Code;  0000000c Before first symbol
   c:   83 c4 04                  add    $0x4,%esp
Code;  0000000f Beforefirst symbol
   f:   eb 03                     jmp    14 <_EIP+0x14> 00000014 Before first sy
mbol
Code;  00000011 Before first symbol
  11:   90                        nop    
Code;  00000012 Before first symbol
  12:   31 db                     xor    %ebx,%ebx



Comment 5 Asbjxrn Sfbx 2000-08-09 07:11:26 UTC
I removed the netscape 4.74-0.6.2 packages, and installed older versions from a
RH-6.1-CD I had lying around:
netscape-navigator-4.7-1.1
netscape-common-4.7-1.1

With these packages, the error is not present, I can access Edit->Preferences
without any problems at all.

Comment 6 Asbjxrn Sfbx 2000-08-09 08:10:01 UTC
No more errors, it seems:

I was trying out various versions of netscape to see if I could reproduce the
error with other packages (which I could not).  And when I finally got around to
reinstalling the versions I have been complaining about, the error is gone. 
Netscape does no longer crash when I acess Edit->Preferences.  

To check or reinstall the packages is probably what I should have done in the
first place, but I did not come to think of it, as they were freshly installed
without errors.  I guess that something may have gone wrong during the update of
the older packages.

One thing I discovered during all this installation and de-installation is that
the packages does not de-install completely with 'rpm -e', there is some cruft
left in /usr/lib/netscape, which causes rpm to complain that it can not remove
that directory.

Comment 7 Bill Nottingham 2000-08-09 16:41:17 UTC
Odd; I haven't seen it here, and since you managed to 'fix'
it with a reinstall of the affected packages, I'm closing
this as WORKSFORME.


Note You need to log in before you can comment on or make changes to this bug.