Bug 15388 - Latin-1 characters on Scandinavian keymaps
Latin-1 characters on Scandinavian keymaps
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: console-tools (Show other bugs)
7.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
: 17000 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-04 09:34 EDT by Christian Rose
Modified: 2008-05-01 11:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-27 13:04:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Rose 2000-08-04 09:34:33 EDT
Opening this RFE as a new bug, as the related bug (bug 14566) was marked as
a MUST-FIX.

It would be nice if the Swedish/Finnish, Danish and Norwegian console
keymaps could have additional latin-1 characters added to them in the
positions shown in http://anubis.dkuug.dk/keld/xkb_latin1.html.

I know that the Swedish X keymap at least already have these modifications
as of RH 6.2, but the console keymap doesn't. Would be nice to bring the
console keymap up to par with the X one.
Comment 1 Bernhard Rosenkraenzer 2000-08-07 09:39:31 EDT
done now. (Quite some work to figure out how some of those odd signs are called
in keymaps ;) )
Comment 2 Christian Rose 2000-08-27 10:40:45 EDT
Some keys seems like they're not working as expected with the Swedish console
keymap in RC2. Some things that don't work are the "enhancements" to the keymap
as mentioned above, other are keys that break the functionality of the standard
keymap.

These are the affected keys:
Shift + "sect" gives a small "oe", instead of a "1/2" sign like it should.
Shift + AltGr + "sect" doesn't work. It should give a "3/4" sign.

Shift + AltGr + "1" doesn't work. It should give a "heightened 1" sign.

Shift + AltGr + "2" doesn't work. It should give a "heightened 2" sign.

Shift + AltGr + "3" doesn't work. It should give a "heightened 3" sign.

Shift + "4" gives an euro sign, instead of the international currency sign like
it should.
Shift + AltGr + "4" doesn't work. It should give a "1/4" sign.

Shift + AltGr + "5" doesn't work. It should give a "cent" sign.
AltGr + "5" gives a "cent" sign, instead of being unused.

Shift + AltGr + "7" doesn't work. It should give a "divide by" sign (the one
with a horisontal bar and two dots).

Shift + AltGr + "8" doesn't work. It should give a "<<" sign.

Shift + AltGr + "9" doesn't work. It should give a ">>" sign.

Shift + AltGr + "0" doesn't work. It should give a "degree" sign (small circle).

Shift + AltGr + "+" doesn't work. It should give an "upside-down ?" sign.

AltGr + "'" gives an "upper right corner" sign, instead of a "+-" sign.
Shift + AltGr + "'" doesn't work. It should give an "upper right corner" sign.

AltGr + "e" gives the Euro sign. This isn't specified in the layouts above, but
it's a great addition, since this is where the Euro sign is placed on newer
Swedish keyboards that have it. Thanks!

AltGr + "t" gives the sign that really should be on Shift + AltGr + "t". AltGr +
"t" should be reserved for the small version of that letter.
Shift + AltGr + "t" doesn't work.

AltGr + "a" gives an "a", instead of a "small underscored a" sign.
Shift + AltGr + "a" doesn't work. It should give a "small underscored o" sign.

AltGr + "s" gives a "s", instead of a "sz" sign (that one that looks like a
"beta" character).

Shift + AltGr + "d" doesn't work. It should give a "D with horisontal bar" sign.

Shift + AltGr + "o diaresis" doesn't work. It should give a capital "o slash"
character.

Shift + AltGr + "a diaresis" doesn't work. It should give a capital "AE"
character.

AltGr + "'" doesn't work. It should give a "straight '" sign.
Shift + AltGr + "'" doesn't work. It should give a "multiply" sign (the one that
looks like an "x").

AltGr + "," doesn't work. It should give a "cedille" sign (and work like a dead
key in that combo).

AltGr + "." doesn't work. It should give a "small centered dot" sign.

AltGr + "-" doesn't work. It should give a "short -" sign.
Shift + AltGr + "-" doesn't work. It should give a "heightened short -" sign.
Comment 3 Bernhard Rosenkraenzer 2000-08-27 10:47:05 EDT
*** Bug 17000 has been marked as a duplicate of this bug. ***
Comment 4 Christian Rose 2000-08-27 10:51:08 EDT
I found this page (http://www.ex.ac.uk/~DCannon/UKprofile/table223.html) with
Latin-1 character names. Hope they can be somewhat helpful...
Comment 5 Bernhard Rosenkraenzer 2000-08-27 10:55:49 EDT
For all the Shift + AltGr + key things: Use Ctrl + key instead. That's the way
the 4th key is handled on German keymaps, so I read the anubis.dkuug.dk page to
mean just that.

Shift + 4 can't be fixed. The Euro sign replaces the international currency sign
in the iso-8859-15 (aka iso-8859-0) keymap. If you need the international
currency sign, use iso-8859-1 or iso-8859-2.
Comment 6 Christian Rose 2000-08-27 11:19:44 EDT
http://www.w3.org/hypertext/WWW/MarkUp/HTMLPlus/htmlplus_table.ps is a
Postscript table with the Latin-1 characters and, among other things, their full
names in Unicode.

I think Shift+AltGr should be used for entering the fourth key, as using Ctrl
breaks common control sequences (as witnessed in my bug 17000) . Shift+AltGr is
also how it already works in the Swedish X keymap.
Comment 7 Bernhard Rosenkraenzer 2000-08-27 13:07:35 EDT
Fixed in -25.
Comment 8 Kjartan Maraas 2000-08-27 14:06:35 EDT
Was this fixed for the Norwegian and Danish keyboards too?

Kjartan
Comment 9 Christian Rose 2000-08-31 01:41:28 EDT
Was this fixed before the Gold release?
Else, an errata might be appropriate. I feel that being able to press control
sequences like Ctrl+C in console mode might be an important feature to a lot of
people.
Comment 10 Bernhard Rosenkraenzer 2000-08-31 05:42:36 EDT
It was fixed in time.

Note You need to log in before you can comment on or make changes to this bug.