Bug 154016 - Error occurs compiling kernel source
Error occurs compiling kernel source
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anil S Keshavamurthy
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-06 11:55 EDT by Rick Hester
Modified: 2007-11-30 17:07 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:05:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix perfmon UP compile (592 bytes, patch)
2005-09-19 05:08 EDT, Stephane Eranian
no flags Details | Diff

  None (edit)
Description Rick Hester 2005-04-06 11:55:08 EDT
Description of problem:
Error occurs during 'make compressed' step of re-compiling kernel source
and compilation aborts.  I don't have the text of the error, but I 
am trying to get that from the team reporting the error.

Version-Release number of selected component (if applicable):
Linux onyx.test 2.4.21-31.EL #1 SMP Thu Mar 10 19:36:07 EST 2005 ia64 ia64 
ia64 GNU/Linux


How reproducible:


Steps to Reproduce:
In the /usr/src/linux-2.4/.config
1.make mrproper
2.cp /boot/config-2.4.21-31.EL /usr/src/linux-2.4/.config
3.make menuconfig, remove the smp support feature and save the .config file.
4.make dep
5.make clean
6.make compressed -  the error will occures. And the process of compile kernel 
aborts 
Actual results:
Compilation of kernel build aborts

Expected results:

Kernel to build without errors.

Additional info:
Comment 1 Ernie Petrides 2005-04-12 16:31:46 EDT
Steps #5-6 don't look right to me.  This is what I do (working from a
clean source tree, not necessarily from installation of kernel-source-*):

  cp configs/kernel-2.4.21-i686-smp.config .config
  make oldconfig
  make dep
  make bzImage
  make modules

Please let me know if "make bzImage" works in place of "make clean" and
"make compressed".
Comment 2 Tim Chambers 2005-04-18 17:08:14 EDT
[forwarding on behalf of jianxun.chen@hp.com]
I think the steps that I provide are right, because on the IA64 platform the
command should be "make compressed":

In the /usr/src/linux-2.4/.config
1.make mrproper
2.cp /boot/config-2.4.21-31.EL /usr/src/linux-2.4/.config
3.make menuconfig, remove the smp support feature and save the .config file.
4.make dep
5.make clean
6.make compressed the error will occure. And the process of compile kernel abort.

I didn't use the make oldconfig because I want to change some options. In this
case I removed the smp support option.

The make bzImage should be used on IA32 platform.
Comment 3 Ernie Petrides 2005-04-19 17:27:20 EDT
Hello, Tim.  You are quite right.  I didn't originally notice that this
was an ia64 kernel build.

The build error is as follows:

  perfmon.c:3491: conflicting types for `pfm_lazy_save_regs'
  perfmon.c:464: previous declaration of `pfm_lazy_save_regs'
  perfmon.c: In function `pfm_load_regs':
  perfmon.c:3750: `this_cpu' undeclared (first use in this function)
  perfmon.c:3750: (Each undeclared identifier is reported only once
  perfmon.c:3750: for each function it appears in.)
  make[1]: *** [perfmon.o] Error 1

This problem was caused by the enabling of the perfmon() system
call for ia64 in U5, with a patch to fix the code submitted by
Stephane Eranian of HP (now added to the cc: list).

Strictly speaking, we don't support non-SMP configurations on ia64.
But if you folks could work with Stephane to develop and test an
incremental ia64 perfmon patch that does work on non-SMP configs,
then we'd be willing to take it into U6.  Otherwise, we'd have to
close this bug as WONTFIX.

For now, I'll leave this bug in NEEDINFO state.  Please let us know
which way you'd like to go.  If you'd like this problem fixed, please
have Stephane attach a patch tested against the latest U5 to this bug.

Thanks.  -ernie
Comment 4 Ernie Petrides 2005-04-19 17:30:31 EDT
I forgot to mention that the ia64 perfmon update was on behalf of bug 112988.
Comment 5 Tim Chambers 2005-04-19 18:22:57 EDT
Adding Suzanne to the list. I know of no customer requirements that would
motivate HP to support non-SMP configurations of ia64. I propose we close this.
Suzanne, what do you say?
Comment 6 Stephane Eranian 2005-04-20 05:16:03 EDT
If you point me at the sources for kernel-2.4.21-31 I could take a quick look
but as you said, I don't think UP configs are ever used.
Comment 7 Ernie Petrides 2005-04-20 15:15:30 EDT
Stephane, please get these through the RHN beta channels.  The latest RPMs
there are for 2.4.21-31.EL, but there was another respin Friday (for -32.EL),
which should appear in the beta channels soon.
Comment 8 Tim Chambers 2005-04-25 13:40:32 EDT
I assume "get these through the RHN beta channels" means we should simply
subscribe a system to the beta channel and use up2date to download the RPM? If
not, please explain how you would do it. I tried that today, and -31.EL is still
the latest that I see. Can you be a little more specific about "soon?" Even
better, could you just put the respin somwhere where Stephane could get it right
away?
Comment 9 Ernie Petrides 2005-04-25 14:07:08 EDT
You can download RPMs directly via rhn.redhat.com (although you'd need
a valid login), and partners should already have been informed how to
download RPMs directly from partners.redhat.com.

Using RHN, just choose the appropriate RHEL v. 3 (arch) beta channel and
then select packages (probably want to use "kernel-" as a filter).  You
can probably use the following URL (once logged in) to isolate the
"kernel-source-2.4.21-31.EL.i386.rpm" RPM and then select "Download RPM"
near the bottom:

  https://rhn.redhat.com/network/software/packages/details.pxt?pid=301945

I've just found out that the -32.EL U5 beta kernel is likely to be loaded
into the associated RHN beta channels later today.  (It's already on the
Partners' FTP site.)
Comment 10 Ernie Petrides 2005-09-12 15:26:55 EDT
Stephane, are you going to follow up on this at some point?
Comment 11 Stephane Eranian 2005-09-16 08:40:20 EDT
Ernie,

I will take a look at this on Monday. But I thought you said it does not
really matter because you do not ship UP kernels.
Comment 12 Ernie Petrides 2005-09-16 15:24:29 EDT
Stephane, you are correct: fixing this is not a requirement of Red Hat's.

But as I wrote in comment #3, if you'd like to help out your HP colleague
Rick Hester by fixing this, then we are open to applying a fix of yours to
the current Update in progress (which is now U7).

If not, just let me know and I'll close this bug as WONTFIX.
Comment 13 Stephane Eranian 2005-09-19 05:08:29 EDT
Created attachment 118964 [details]
Fix perfmon UP compile

Ernie,

Here is a patch that should fix your compilation problem in UP mode.
It is relative to the U6 kernel source.
Comment 14 Ernie Petrides 2005-09-19 14:33:25 EDT
Thanks, Stephane.

Geoff, when you test this, please make sure it compiles in both the
normal (SMP) build and in the re-config'ed non-SMP build (as described
in the initial comment of this bug report).
Comment 15 Michael Raskey 2006-03-03 13:15:08 EST
Tried to compile the kernel on RHEL3 U7 beta, and the following error occured:

gcc -D__KERNEL__ -I/usr/src/linux-2.4.21-38.EL/include -Wall -Wstrict-
prototypes -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common  -Wno-unused -
fomit-frame-pointer -pipe  -ffixed-r13 -mfixed-range=f10-f15,f32-f127 -falign-
functions=32 -frename-registers --param max-inline-insns=5000 -mconstant-gp  -
nostdinc -iwithprefix include -DKBUILD_BASENAME=ia64_ksyms  -
DEXPORT_SYMTAB -c ia64_ksyms.c
ia64_ksyms.c:210: `pm_power_off' undeclared here (not in a function)
ia64_ksyms.c:210: initializer element is not constant
ia64_ksyms.c:210: (near initialization for `__ksymtab_pm_power_off.value')
make[1]: *** [ia64_ksyms.o] Error 1
make[1]: Leaving directory `/usr/src/linux-2.4.21-38.EL/arch/ia64/kernel'
make: *** [_dir_arch/ia64/kernel] Error 2

[root@rx2600-2 linux-2.4]# uname -a
Linux rx2600-2 2.4.21-39.EL #1 SMP Fri Jan 20 18:40:17 EST 2006 ia64 ia64 ia64 
GNU/Linux

Was the patch applied?
Was is supposed to make it into Update 7?
Comment 16 Ernie Petrides 2006-03-03 15:37:24 EST
This bug was recently reassigned from Geoff to Anil.  No patch was
ever posted internally, and so no, the fix did not make it into U7.
Comment 17 Anil S Keshavamurthy 2006-03-03 16:23:48 EST
In my view, these kinds of fixes should not be encouraged. Once we fix this
particular compile issues, we might see some other compile bug for UP and it is
not worth atacking all those bugs. Since this UP configuration is totally
unsupported by Red Hat and their could very well be boot or stability issues too
with the built UP kernel.

Unless the priority of this bug is raised high,
I will not going to look at this bug for now.

Comment 18 RHEL Product and Program Management 2007-10-19 15:05:20 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.