Bug 154080 - No sound after kernel upgrade from 2.6.9 to 2.6.10
No sound after kernel upgrade from 2.6.9 to 2.6.10
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-06 23:50 EDT by Mark
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-13 09:35:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
lspci, dmesg, and lsmod output (33.25 KB, text/plain)
2005-04-06 23:50 EDT, Mark
no flags Details
lspci -vv; dmesg; lsmod output (26.50 KB, text/plain)
2005-04-18 12:08 EDT, david d zuhn
no flags Details

  None (edit)
Description Mark 2005-04-06 23:50:59 EDT
Description of problem:
A clean install of Fedora Core 3 Distro downloaded around 3/24/2005, most files
last modified time is 11/3/2004 - with kernel 2.6.9-1.667.

Hardware:
Motherboard: Soyo SY-P4RC350
CPU: Intel Celeron D 2.8Ghz
RAM: 512MB
HDD: Seagate Baracuda 250GB ATA133
Sound: Integrated AC'97 6 Channel sound
Video: Onboard (not in use), Radeon 9600 Pro AGP (in use)

After initial package installation with kernel 2.6.9-1.667 (clean system)...
-Sound config plays sample sound without any further modifications (i.e. sound
works on first boot after setup/install)


Via apt package installer, upgrade all components, including kernel. Kernel
upgraded to 2.6.10-1.770_FC3...
-Sound does not work.

Attempts made:
1. Unmute all sound devices via alsamixer, aumix, amixer, and Gnome GUI sound
mixer. Also combinations of mute/unmute have been tried for unfamiliar devices
(like IEC958). Also, there is no "auto sense headphone jack" volume control -
tried that.
2. Boot with the following arguments: acpi=off, acpi=noirq
3. Disabled acpid in all runlevels
4. Modify /etc/modprobe.conf. Remove default distro entries and replace with
suggested entries from alsa-project.org (for the atiixp chipset).
5. Copied /etc/asound.state from a 2.6.9-1.667 boot, to /etc and chmod 400 (in
hopes that it won't be overwritten).
6. Tried plugging in headphones

All attempts yield the same result - sound works in 2.6.9-1.667, sound does not
work in 2.6.10-1.770_FC3.

I've searched bugzilla and numerous other forums (fedoraforum.org,
linuxquestions.org to name a few) and none of the fixes for anything similar to
this issue worked.

Thanks in advance for your time.

Version-Release number of selected component (if applicable):


How reproducible:
Every time

Steps to Reproduce:
1. Install Fedora Core 3 kernel 2.6.9-1.667 (on system using Soyo SY-P4RC350
motherboard and integrated AC'97 sound)
2. Test sound - sound test successful
3. Update kernel to 2.6.10-1.770_FC3
4. Test sound - sound test failed
    
Actual results:
lspci shows sound modules loaded (snd-atiixp) for both kernels.
the system (using aplay or xmms) "seems" to play sound, but no sound coming from
speakers.


Expected results:
sound should be coming from the speakers

Additional info:
In attachment find output from each kernel boot for lspci, dmesg, and lsmod.
Comment 1 Mark 2005-04-06 23:50:59 EDT
Created attachment 112799 [details]
lspci, dmesg, and lsmod output
Comment 2 Martin Stransky 2005-04-07 07:20:55 EDT
Did you try to executed alsaconf?
Comment 3 Mark 2005-04-07 08:41:00 EDT
(In reply to comment #2)
> Did you try to executed alsaconf?

Alsaconf adds some lines to /etc/modprobe.conf (included below). I've tried
booting when modprobe.conf only includes the lines added by alsconf and I've
tried booting with the modprobe.conf included below. No sound with either. It
seems that sound is "working", but nothing is coming out of the speakers. And
again, booting to the 2.6.9 kernel, sound is fine.

Thanks again for your time.

#####
alias eth0 via-velocity
alias snd-card-0 snd-atiixp
options snd-card-0 index=0
install snd-atiixp /sbin/modprobe --ignore-install snd-atiixp &&
/usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-atiixp { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-atiixp
alias usb-controller ehci-hcd

# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF verion 1.0.8 ---
alias snd-card-0 snd-atiixp
alias sound-slot-0 snd-atiixp
# --- END: Generated by ALSACONF, do not edit. ---

Comment 4 Martin Stransky 2005-04-07 09:16:24 EDT
It's realy hard to say where is the problem, because 2.6.10-1.770_FC3
and 2.6.9-1.667 have the same alsa-drivers (1.0.6). I'll check if
there is any diference, but i think that isn't.

Or you can try to use 2.6.9-10 kernel from devel, with alsa-drivers
1.0.8, it maybee can help. (In this case, you will need alsa packages
- lib&utils from devel)
Comment 5 david d zuhn 2005-04-18 12:07:33 EDT
I've seen the same thing with my eMachines M2350 laptop --
kernel-2.6.9-1.678_FC3 works with the builtin speakers, while any later kernel
does not (the first one that I have that doesn't work is
kernel-2.6.10-1.741_FC3),   Note that the headphones work with all kernels, it's
just the speakers that no longer work.
Comment 6 david d zuhn 2005-04-18 12:08:29 EDT
Created attachment 113328 [details]
lspci -vv; dmesg; lsmod output
Comment 7 Martin Stransky 2005-04-20 06:31:11 EDT
You can fill bug report for alsa-project
(http://www.alsa-project.org/), but I think better can be upgrade to
new alsa drivers in Fedora 4...
Comment 8 Martin Stransky 2005-06-20 12:09:41 EDT
Any news with the new FC release?
Comment 9 david d zuhn 2005-06-20 12:24:45 EDT
I have checked FC4, and I don't have sound via the builtin speakers. 
I have not had a chance to check the headphone jack.
Comment 10 Martin Stransky 2006-01-03 10:29:38 EST
Some how-to for the latest alsa-driver and FC4 is here:
http://people.redhat.com/stransky/alsa/
Comment 11 Martin Stransky 2006-03-13 09:35:27 EST
Please reopen if you have some new info...

Note You need to log in before you can comment on or make changes to this bug.