Bug 154204 - It is unclear what it refers to in system-config-users messages
It is unclear what it refers to in system-config-users messages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-users (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
: i18n, StringChange
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-08 08:34 EDT by Christian Rose
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-05 11:04:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Rose 2005-04-08 08:34:01 EDT
#: ../src/mainWindow.py:639
msgid "- It is part of an installed software package."

#: ../src/mainWindow.py:641
msgid ""
"- It belongs to a system user and removing it may impair the system's "
"integrity."

#: ../src/mainWindow.py:643
msgid "- It doesn't exist or isn't writable."

#: ../src/mainWindow.py:645
#, python-format
msgid "- It isn't owned by the user '%s'."

I doubt that starting a new paragraph with "it" is good English.
In any case, starting a new paragraph or seperately marked message with "it"
causes big problems for translation, because in many languages, the "it" or
other parts of the sentences may need different translations, depending on what
object the "it" actually refers to.

I would recommend that these sentences are rephrased, and made stand-alone and
complete, i.e.:

  "I could not delete the foo %s, because it doesn't exist."

  "I could not delete the foo %s, because it is part of an installed software
package."

  ...

This would result in more messages, but they would probably end up being better
English, and they would be much easier to translate, and it would be possible to
translate them correctly, which isn't the case now.
Comment 1 Nils Philippsen 2006-04-05 11:04:57 EDT
I've fixed this in rhlinux CVS.
Comment 2 Nils Philippsen 2006-04-05 11:09:56 EDT
system-config-users-1.2.44-1 is building right now in Rawhide.

Note You need to log in before you can comment on or make changes to this bug.