Bug 154346 - freeradius-debuginfo package missing
freeradius-debuginfo package missing
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: distribution (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: RHEL Product and Program Management
Daniel Riek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-10 13:55 EDT by Graham Leggett
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:04:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Graham Leggett 2005-04-10 13:55:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20050130 Fedora/1.7.5-3

Description of problem:
When configuring freeradius, an attempt to authenticate against it causes a segfault. An attempt is made to run the program through gdb to get a clue as to the origin of the failure, but the symbols have been stripped and are missing.

A search for a freeradius-debuginfo package comes up empty.

Please publish a debuginfo package so that gdb debugging becomes meaningful.

(The segfault will be posted as a separate bug).


Version-Release number of selected component (if applicable):
1.0.1-1.RHEL3

How reproducible:
Always

Steps to Reproduce:
xxx

Additional info:
Comment 1 Thomas Woerner 2005-04-11 07:00:37 EDT
You can either get the debuginfo package on 

http://people.redhat.com/twoerner/RPMS/3.0E/freeradius-debuginfo-1.0.1-1.RHEL3.i386.rpm

Or you can compile for your own. Get the source RPM and make an "rpmbuild --rebuild"

What problems do you have with the authentication?



----
Please remember that rebuilds and debuginfo packages are not signed and unsupported.
Comment 2 Graham Leggett 2005-04-11 15:57:26 EDT
The problem is that I did compile my own package, adding the  --enable-developer
within the spec file to get debugging symbols in the hope of getting a
meaningful backtrace, and the server promptly stopped segfaulting and started
working flawlessly.

There is no documentation anywhere as to where the debuginfo packages are (the
people.redhat.com website is not the first place to look for RPMs). The missing
debuginfo packages mean that I cannot give you feedback about problems with
_redhat_ supported packages - I am now running my own build from SRPM.

The original problem was that when freeradius was set up to use EAP to serve a
wireless access point using WPA via radius via LDAP, the freeradius server would
segfault on the first attempt by a wireless client to connect. I got a
backtrace, but as no symbols were present the backtrace was meaningless.
Comment 3 Thomas Woerner 2006-06-07 06:09:14 EDT
Assigning to distribution.
Comment 4 RHEL Product and Program Management 2007-10-19 15:04:49 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.